aboutsummaryrefslogtreecommitdiffstats
path: root/community/lxsession
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:47:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 00:02:54 -0300
commit3111d28ed20cc290d61f5716d7d31df95e40fe28 (patch)
tree08aa027bda3e46096e0559c52a316197b92f2f76 /community/lxsession
parentdf527287d61ff87b1ae2205e5eb9618b73685628 (diff)
downloadaports-3111d28ed20cc290d61f5716d7d31df95e40fe28.tar.bz2
aports-3111d28ed20cc290d61f5716d7d31df95e40fe28.tar.xz
community/lxsession: move from main
Diffstat (limited to 'community/lxsession')
-rw-r--r--community/lxsession/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/lxsession/APKBUILD b/community/lxsession/APKBUILD
new file mode 100644
index 0000000000..4e3628274c
--- /dev/null
+++ b/community/lxsession/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lxsession
+pkgver=0.5.4
+pkgrel=0
+pkgdesc="Lightweight X11 session manager"
+url="https://wiki.lxde.org/en/LXSession"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="gtk+-dev dbus-glib-dev polkit-dev libunique-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://downloads.sourceforge.net/sourceforge/lxde/lxsession-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5b92d6e703ef692e3788554a3a34eca7bb4b7bb23d735af838c35bfaab142238eaeee3095176e5e4a7464468ab5478a596c670b0e2488f8599091f3e2fc8482b lxsession-0.5.4.tar.xz"