aboutsummaryrefslogtreecommitdiffstats
path: root/community/makekit
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-23 19:35:13 +0100
committerTBK <tbk@jjtc.eu>2020-03-23 19:35:25 +0100
commit9050d0a73d157e4bec1360c404a663012ee75f6f (patch)
tree8e4ae89da10a968bfc17f2f53a3f3cc819ed7c54 /community/makekit
parentbc5bdeaee9133ca6c5ef9268c842fc09e5bb573e (diff)
downloadaports-9050d0a73d157e4bec1360c404a663012ee75f6f.tar.bz2
aports-9050d0a73d157e4bec1360c404a663012ee75f6f.tar.xz
community/makekit: fix build
>>> makekit: Unpacking /var/cache/distfiles/makekit-0.2.tar.gz... /usr/bin/abuild: line 16: ./configure: not found >>> ERROR: makekit: build failed >>> makekit: Uninstalling dependencies...
Diffstat (limited to 'community/makekit')
-rw-r--r--community/makekit/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/makekit/APKBUILD b/community/makekit/APKBUILD
index 5c44a043fe..398413274a 100644
--- a/community/makekit/APKBUILD
+++ b/community/makekit/APKBUILD
@@ -3,17 +3,23 @@
pkgname=makekit
pkgver=0.2
pkgrel=0
-pkgdesc="modular build system for POSIX environments"
-url="http://mkbuild.sourceforge.net/"
+pkgdesc="Modular build system for POSIX environments"
+url="https://bkoropoff.github.io/makekit"
arch="x86 x86_64"
license="BSD-3-Clause"
+options="!check" # No test suite
makedepends="coreutils"
-options="!check"
-source="makekit-$pkgver.tar.gz::https://github.com/bkoropoff/makekit/archive/release-$pkgver.tar.gz"
-builddir="$srcdir"/makekit-release-$pkgver/build
+source="$pkgname-$pkgver.tar.gz::https://github.com/bkoropoff/makekit/archive/release-$pkgver.tar.gz"
+builddir="$srcdir/makekit-release-$pkgver"
+
+prepare() {
+ default_prepare
+ mkdir build
+}
build() {
- ./configure \
+ cd build
+ ../configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -25,7 +31,7 @@ build() {
}
package() {
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="7746141b253953212d621f9c4a8376b5c6bd3ac15d1809b184013a27c51006be2e2ee5ef391509486ae89b7fdca81863f8c916538bcb98e435ebf0ff1976f1ce makekit-0.2.tar.gz"