aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-notification-daemon
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:09 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commitd9fe9419d8e28d84721c4734e97adf2b8f0cdb4a (patch)
tree8abdd25ff65ab5f32b19538980a1ce1e0d337ed3 /community/mate-notification-daemon
parent47dfe5d129ba805ab3d0ae09baa87e9f25020da4 (diff)
downloadaports-d9fe9419d8e28d84721c4734e97adf2b8f0cdb4a.tar.bz2
aports-d9fe9419d8e28d84721c4734e97adf2b8f0cdb4a.tar.xz
main/mate-notification-daemon: move to community
Diffstat (limited to 'community/mate-notification-daemon')
-rw-r--r--community/mate-notification-daemon/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/mate-notification-daemon/APKBUILD b/community/mate-notification-daemon/APKBUILD
new file mode 100644
index 0000000000..646e6a387b
--- /dev/null
+++ b/community/mate-notification-daemon/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-notification-daemon
+pkgver=1.10.2
+pkgrel=0
+pkgdesc="Small, passive popup dialogs that notify the user of particular events"
+url="https://github.com/mate-desktop/mate-notification-daemon"
+arch="all"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev libwnck-dev libnotify-dev libtool intltool dbus-glib-dev
+ libcanberra-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --with-gtk=2.0 \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="c3beee80a10efebf82fed86a0346fe93 mate-notification-daemon-1.10.2.tar.xz"
+sha256sums="f421deaf684368cc426954bbd6ecd1aa518fa50f44c03e0f68a50ae8aa9b35b3 mate-notification-daemon-1.10.2.tar.xz"
+sha512sums="6b7cc9c7450da340c2a6061307c46a0fdabb4ff28fd6dfa12180f4007fcd33ea936d767abae19c571e6f63fa8a261df40dfc2bfb38d8efebbe9becc4ba16dbcc mate-notification-daemon-1.10.2.tar.xz"