aboutsummaryrefslogtreecommitdiffstats
path: root/community/mbedtls/verbose-testsuite.patch
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-10-20 23:31:19 -0400
committerTimo Teräs <timo.teras@iki.fi>2016-11-04 06:56:59 +0000
commit156d008505827a7e207999c1ec0a00a4c5f022cc (patch)
tree489935ba0cffa2ef0fd56bc9acc767b81eeacc2e /community/mbedtls/verbose-testsuite.patch
parenta7aa1a25085f8444e52d6da2a87676ce2dff880f (diff)
downloadaports-156d008505827a7e207999c1ec0a00a4c5f022cc.tar.bz2
aports-156d008505827a7e207999c1ec0a00a4c5f022cc.tar.xz
community/mbedtls: security upgrade to 2.4.0
With verbosity disabled (default), the testsuite attempts to redirect stdout by assigning another FILE pointer to it. Enabling verbosity seems to be the simplest workaround to avoid this code path.
Diffstat (limited to 'community/mbedtls/verbose-testsuite.patch')
-rw-r--r--community/mbedtls/verbose-testsuite.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/mbedtls/verbose-testsuite.patch b/community/mbedtls/verbose-testsuite.patch
new file mode 100644
index 0000000000..e039c27ca1
--- /dev/null
+++ b/community/mbedtls/verbose-testsuite.patch
@@ -0,0 +1,11 @@
+--- mbedtls-2.4.0/tests/CMakeLists.txt.orig
++++ mbedtls-2.4.0/tests/CMakeLists.txt
+@@ -31,7 +31,7 @@
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+ add_executable(test_suite_${data_name} test_suite_${data_name}.c)
+ target_link_libraries(test_suite_${data_name} ${libs})
+- add_test(${data_name}-suite test_suite_${data_name})
++ add_test(${data_name}-suite test_suite_${data_name} --verbose)
+ endfunction(add_test_suite)
+
+ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_CLANG)