aboutsummaryrefslogtreecommitdiffstats
path: root/community/mbedtls
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-03-30 13:21:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 20:20:28 +0000
commitfba3fdbd4173920d27134bd08c14c9e4faa1c043 (patch)
treed6ca1a1c876dded33a3cfa989e1acc4517fd0454 /community/mbedtls
parent64e758e582bc124c5210768d2aff100cf0d5e306 (diff)
downloadaports-fba3fdbd4173920d27134bd08c14c9e4faa1c043.tar.bz2
aports-fba3fdbd4173920d27134bd08c14c9e4faa1c043.tar.xz
community/mbedtls: upgrade to 2.11.0
Diffstat (limited to 'community/mbedtls')
-rw-r--r--community/mbedtls/APKBUILD11
-rw-r--r--community/mbedtls/dhm-Fix-typo-in-RFC-5114-constants.patch26
-rw-r--r--community/mbedtls/verbose-testsuite.patch11
3 files changed, 4 insertions, 44 deletions
diff --git a/community/mbedtls/APKBUILD b/community/mbedtls/APKBUILD
index baf9936f12..23620970d3 100644
--- a/community/mbedtls/APKBUILD
+++ b/community/mbedtls/APKBUILD
@@ -1,17 +1,15 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mbedtls
-pkgver=2.7.0
+pkgver=2.11.0
pkgrel=0
pkgdesc="Light-weight cryptographic and SSL/TLS library"
-url="https://tls.mbed.org/"
+url="https://tls.mbed.org"
arch="all"
license="GPL-2.0-or-later Apache-2.0"
makedepends="cmake perl"
subpackages="$pkgname-static $pkgname-dev $pkgname-utils"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ARMmbed/$pkgname/archive/$pkgname-$pkgver.tar.gz
- dhm-Fix-typo-in-RFC-5114-constants.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/ARMmbed/$pkgname/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
# secfixes:
@@ -70,5 +68,4 @@ static() {
chmod -x "$subpkgdir"/usr/lib/*.a
}
-sha512sums="411ec25d2cd51abbbfa2312195c4e65aa578855f6f909b8668375e6f5ce5401a00153cb4790328daaf85cd2d0ce647dbcc9fa556331e2d14709ba64aff883867 mbedtls-2.7.0.tar.gz
-cc8c012a32a97f3c516d84c17df1911628178ffce7c6efc829258a7bad10951949c04ab770d88883a84a566fbe40de1cd60bfdfa986be813f5dbe883b601b042 dhm-Fix-typo-in-RFC-5114-constants.patch"
+sha512sums="301ddc6757be32aaa8ddbfd6c665a1d78c4869007a5aff954b54479c26f90d25bbfcb8c866dd6ae73a8222123928355e84ca5b59d24512d2bfdf1cdc41050e29 mbedtls-2.11.0.tar.gz"
diff --git a/community/mbedtls/dhm-Fix-typo-in-RFC-5114-constants.patch b/community/mbedtls/dhm-Fix-typo-in-RFC-5114-constants.patch
deleted file mode 100644
index be994df9f1..0000000000
--- a/community/mbedtls/dhm-Fix-typo-in-RFC-5114-constants.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 129f50838bf14f4e1319f06f41c827fae9cc4b73 Mon Sep 17 00:00:00 2001
-From: Jaeden Amero <jaeden.amero@arm.com>
-Date: Thu, 8 Feb 2018 14:25:36 +0000
-Subject: [PATCH] dhm: Fix typo in RFC 5114 constants
-
-We accidentally named the constant MBEDTLS_DHM_RFC5114_MODP_P instead of
-MBEDTLS_DHM_RFC5114_MODP_2048_P.
-
-Fixes #1358
----
- include/mbedtls/dhm.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/mbedtls/dhm.h b/include/mbedtls/dhm.h
-index da2e66b111..00fafd8d16 100644
---- a/include/mbedtls/dhm.h
-+++ b/include/mbedtls/dhm.h
-@@ -372,7 +372,7 @@ MBEDTLS_DEPRECATED typedef char const * mbedtls_deprecated_constant_t;
- * in <em>RFC-5114: Additional Diffie-Hellman Groups for Use with
- * IETF Standards</em>.
- */
--#define MBEDTLS_DHM_RFC5114_MODP_P \
-+#define MBEDTLS_DHM_RFC5114_MODP_2048_P \
- MBEDTLS_DEPRECATED_STRING_CONSTANT( \
- "AD107E1E9123A9D0D660FAA79559C51FA20D64E5683B9FD1" \
- "B54B1597B61D0A75E6FA141DF95A56DBAF9A3C407BA1DF15" \
diff --git a/community/mbedtls/verbose-testsuite.patch b/community/mbedtls/verbose-testsuite.patch
deleted file mode 100644
index e039c27ca1..0000000000
--- a/community/mbedtls/verbose-testsuite.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mbedtls-2.4.0/tests/CMakeLists.txt.orig
-+++ mbedtls-2.4.0/tests/CMakeLists.txt
-@@ -31,7 +31,7 @@
- include_directories(${CMAKE_CURRENT_SOURCE_DIR})
- add_executable(test_suite_${data_name} test_suite_${data_name}.c)
- target_link_libraries(test_suite_${data_name} ${libs})
-- add_test(${data_name}-suite test_suite_${data_name})
-+ add_test(${data_name}-suite test_suite_${data_name} --verbose)
- endfunction(add_test_suite)
-
- if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_CLANG)