aboutsummaryrefslogtreecommitdiffstats
path: root/community/mblaze
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-05-19 22:46:08 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-05-20 11:33:04 +0200
commitf66ad3104ada47d2fbbc45344fbc5b4be9886779 (patch)
tree47a161ccbea4ec983a8ca7c24ee567cac705c6d0 /community/mblaze
parentb4750990ccffa1949f636fe2fa9ce3b129f69855 (diff)
downloadaports-f66ad3104ada47d2fbbc45344fbc5b4be9886779.tar.bz2
aports-f66ad3104ada47d2fbbc45344fbc5b4be9886779.tar.xz
community/mblaze: add crypto subpackage for S/MIME and OpenPGP
The README.md in the contrib directory states that: [These] scripts [...] are not officially supported or subject to any robustness, portability or stability criteria. However, the scripts for S/MIME and OpenPGP work quite well and are very useful thus I believe that it is worth it to ship these in a subpackage.
Diffstat (limited to 'community/mblaze')
-rw-r--r--community/mblaze/APKBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/community/mblaze/APKBUILD b/community/mblaze/APKBUILD
index 2d4794acc1..88d84bdf72 100644
--- a/community/mblaze/APKBUILD
+++ b/community/mblaze/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=mblaze
pkgver=0.3.2
-pkgrel=2
+pkgrel=3
pkgdesc="Unix utilities to deal with Maildir"
url="https://github.com/chneukirchen/mblaze"
arch="all"
@@ -12,7 +12,7 @@ depends_dev=""
makedepends=""
checkdepends="perl-utils"
install=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-crypto"
options="!check" # currently fail on the builder
source="$pkgname-$pkgver.tar.gz::https://github.com/chneukirchen/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -35,4 +35,14 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/
}
+crypto() {
+ depends="libressl gnupg"
+ pkgdesc="Scripts for using S/MIME and PGP"
+
+ cd "$builddir/contrib"
+ mkdir -p "$subpkgdir"/usr/bin
+ install -m755 mverify msign mencrypt mgpg \
+ "$subpkgdir"/usr/bin
+}
+
sha512sums="809d3a82e89a90bf1dce5abca97155b524290bbaa3c8100efb461f3694c4ff28ed0d1e46d3d74c2fbb96a17cd44ccee315a022d6697a470f82d8d4ee66ab7147 mblaze-0.3.2.tar.gz"