aboutsummaryrefslogtreecommitdiffstats
path: root/community/midori/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-10-28 15:59:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-10-28 15:59:18 +0000
commit9e581eee8d5bfd327be2a1d04927da4baed62460 (patch)
tree2f9a9928cbdd1dab97a06f8a889126d4605442ec /community/midori/APKBUILD
parente99310f967946358b74c86fa77143dbda6f630bf (diff)
downloadaports-9e581eee8d5bfd327be2a1d04927da4baed62460.tar.bz2
aports-9e581eee8d5bfd327be2a1d04927da4baed62460.tar.xz
community/midori: move from main
Diffstat (limited to 'community/midori/APKBUILD')
-rw-r--r--community/midori/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/midori/APKBUILD b/community/midori/APKBUILD
new file mode 100644
index 0000000000..5cb98be108
--- /dev/null
+++ b/community/midori/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=midori
+pkgver=0.5.10
+pkgrel=0
+pkgdesc="A lightweight web browser based on Gtk WebKit"
+url="http://www.midori-browser.org"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="libnotify-dev libunique-dev webkitgtk-dev"
+makedepends=" $depends_dev cmake librsvg-dev paxmark python vala gcr-dev"
+subpackages="$pkgname-lang"
+install=""
+source="http://www.midori-browser.org/downloads/midori_${pkgver}_all_.tar.bz2
+ execinfo-detect.patch
+ "
+
+_builddir="$srcdir"/
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DUSE_ZEITGEIST=OFF \
+ . || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ # PAX does not like the JIT
+ paxmark -mp "$pkgdir"/usr/bin/midori || return 1
+}
+
+md5sums="2f250a5015923b6eeca606629e7bf042 midori_0.5.10_all_.tar.bz2
+38acb831d862fa8d9aaa9097b4180840 execinfo-detect.patch"
+sha256sums="702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f midori_0.5.10_all_.tar.bz2
+cc8c5f1402aa7785d67df96f05c72dcbe74c67624834f427e09ceb44ab6d73c7 execinfo-detect.patch"
+sha512sums="9e615581b2029e2167d13bab3a580cf89b87da4979bb27982f2002b4ddb97e44d27ea910ee60df6479bd0dfa8cbef75217fa1956eb34b13475c99ab25b83f245 midori_0.5.10_all_.tar.bz2
+20cd27a801bf1dcf1c9e4e4642a4a342f5a70e0f97843b155588c80f1e4976dd6f8fd95d5e2d6c416de3f7181d0719e3e04d2d09b6a8d105df4510ef0090bc45 execinfo-detect.patch"