aboutsummaryrefslogtreecommitdiffstats
path: root/community/milou
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/milou
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/milou')
-rw-r--r--community/milou/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/milou/APKBUILD b/community/milou/APKBUILD
index ffa34958fe..38655c7fb4 100644
--- a/community/milou/APKBUILD
+++ b/community/milou/APKBUILD
@@ -1,19 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=milou
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="A dedicated search application built on top of Baloo"
arch="all"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev ki18n-dev kdeclarative-dev kservice-dev plasma-framework-dev krunner-dev"
-makedepends="$depends_dev extra-cmake-modules"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev ki18n-dev kdeclarative-dev kservice-dev plasma-framework-dev krunner-dev kitemmodels-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/milou-$pkgver.tar.xz"
subpackages="$pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -21,10 +27,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="70f8ab1c7dc1d3724e385cc959f3ad4b80efbd200c0dd9028cb123a07304b0c866c3a8a474cb5dcd0d2358a6b0ed888c85f0f6b8f43d8e057b16152406ea8ead milou-5.16.5.tar.xz"
+sha512sums="9af926d737752905006edd904ca7ffb6d82e6fada9621cc2c9dba9c4d4fd8ac9168fcc6d97b0fa145b990cc3f9911495e4901d60d101f00c90bef37cf5bab816 milou-5.17.0.tar.xz"