aboutsummaryrefslogtreecommitdiffstats
path: root/community/mktorrent
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 15:28:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 15:28:08 +0000
commit7d559d443c1e049df669035aea32e5c3b7e2d4d6 (patch)
tree9f43b0f4369a1c44e09c094f142e4097d99eb1dc /community/mktorrent
parent8aa34288216ce1ec3f9e2cbae00a77235a02774c (diff)
downloadaports-7d559d443c1e049df669035aea32e5c3b7e2d4d6.tar.bz2
aports-7d559d443c1e049df669035aea32e5c3b7e2d4d6.tar.xz
commit/mktorrent: moved from testing
Diffstat (limited to 'community/mktorrent')
-rw-r--r--community/mktorrent/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/mktorrent/APKBUILD b/community/mktorrent/APKBUILD
new file mode 100644
index 0000000000..918e3b76e3
--- /dev/null
+++ b/community/mktorrent/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=mktorrent
+pkgver=0.9.9
+pkgrel=1
+pkgdesc="A handy tool for creating .torrent files"
+url="http://borg.uu3.net/~borg/?mktorrent"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="openssl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://borg.uu3.net/pub/unix/$pkgname/$pkgname-${pkgver}.tgz"
+builddir="$srcdir"/$pkgname
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -D -m755 mktorrent $pkgdir/usr/bin/mktorrent-borg
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/mktorrent/LICENSE
+}
+
+md5sums="8bdfa36982446f3ccd8549fedefb7448 mktorrent-0.9.9.tgz"
+sha256sums="d9dc38d13dffe817c4e20c9c489b0e46a0f2b9ae2bc0367d5e6bba8e5cdde83f mktorrent-0.9.9.tgz"
+sha512sums="ff702383c99d5c80b4433fb279968e1f19c6315216a2b74064ba57240ecd990b674195c035278c7e54801b77ab76fbb94667d8d7938d5ce2348faf015de27c5f mktorrent-0.9.9.tgz"