aboutsummaryrefslogtreecommitdiffstats
path: root/community/mongodb-tools
diff options
context:
space:
mode:
authorMarc Vertes <mvertes@free.fr>2017-08-12 15:57:36 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-22 22:25:18 +0200
commitc8937bdb8552e853b66efdadf255f0c3a369bf67 (patch)
tree7b3593bdc1b72fd2ce69504dafaeba5b7a71116e /community/mongodb-tools
parenta4cdbe61fa3af398fdd522b49565dfeec4141042 (diff)
downloadaports-c8937bdb8552e853b66efdadf255f0c3a369bf67.tar.bz2
aports-c8937bdb8552e853b66efdadf255f0c3a369bf67.tar.xz
community/mongodb-tools: upgrade to 3.4.7
Diffstat (limited to 'community/mongodb-tools')
-rw-r--r--community/mongodb-tools/APKBUILD13
-rw-r--r--community/mongodb-tools/libressl.patch13
2 files changed, 19 insertions, 7 deletions
diff --git a/community/mongodb-tools/APKBUILD b/community/mongodb-tools/APKBUILD
index 0f8d73ed89..72d49efc65 100644
--- a/community/mongodb-tools/APKBUILD
+++ b/community/mongodb-tools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Marc Vertes <marc.vertes@ugrid.net>
# Maintainer: Marc Vertes <marc.vertes@ugrid.net>
pkgname=mongodb-tools
-pkgver=3.4.4
-pkgrel=2
+pkgver=3.4.7
+pkgrel=0
pkgdesc="The MongoDB tools provide import, export, and diagnostic capabilities."
url="https://github.com/mongodb/mongo-tools"
arch="all !s390x !aarch64"
@@ -10,9 +10,10 @@ license="apache"
makedepends="$depends_dev go cyrus-sasl-dev libressl-dev libpcap-dev"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo-tools/archive/r$pkgver.tar.gz
- libressl.patch
fix-build.patch
+ libressl.patch
"
+
builddir="$srcdir"/mongo-tools-r$pkgver
prepare() {
@@ -32,6 +33,6 @@ package() {
cp bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongooplog mongoreplay "$bindir" || return 1
}
-sha512sums="d49243e41bf3144264add3766a6f7016a07509a583a7368a639d85d2305500dd5afcfbc4449f3dcc8bec6e88bfb76ce021c813fe14169e3bd2476ed0db7c2d5d mongodb-tools-3.4.4.tar.gz
-3e336b01c33da66623cc84bf9c29c794bba20bdaf6299713f39416ed1a92406c6f2e5e03865aaca128f91e8e1ac64c6c52a2a92610c59dc7be2fd6c997e9361e libressl.patch
-74e432b354fd75209b87461e54f79a173ba0d647a2e45a48d520ee9342236b6a50ef1c634312f4804402578b8534d59ebf10973ce90cae2bbe76407102f2b404 fix-build.patch"
+sha512sums="4ccc77c858f88f57f6b29bfc56361efc3362782fe82e8d73474202ca02c0cad49134f622dcc36cba669b37ac19e869cc76e07254a9eb26e9c175f8bad104a07d mongodb-tools-3.4.7.tar.gz
+74e432b354fd75209b87461e54f79a173ba0d647a2e45a48d520ee9342236b6a50ef1c634312f4804402578b8534d59ebf10973ce90cae2bbe76407102f2b404 fix-build.patch
+ddc4a5a93717dbaa6b6b816bdaaecaa6990c6b8fdf390f37e98d358cdffb9561a8ffb34a2af2c170fee7d181d343f2090b3b1a36ac4989bcc67ca493faeb946e libressl.patch"
diff --git a/community/mongodb-tools/libressl.patch b/community/mongodb-tools/libressl.patch
index 0afd28f98c..0663627567 100644
--- a/community/mongodb-tools/libressl.patch
+++ b/community/mongodb-tools/libressl.patch
@@ -18,4 +18,15 @@
import "C"
-const Version string = C.OPENSSL_VERSION_TEXT
-+const Version string = "LibreSSL 2.4.5"
++const Version string = "LibreSSL 2.5.5"
+--- mongo-tools-r3.4.7/vendor/src/github.com/spacemonkeygo/openssl/init_posix.go.orig
++++ mongo-tools-r3.4.7/vendor/src/github.com/spacemonkeygo/openssl/init_posix.go
+@@ -52,7 +52,7 @@
+ return rc;
+ }
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ void Goopenssl_thread_locking_callback(int mode, int n, const char *file,
+ int line) {
+ if (mode & CRYPTO_LOCK) {