aboutsummaryrefslogtreecommitdiffstats
path: root/community/monitoring-plugins
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-11 17:30:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-11 17:32:01 +0000
commitf073ab96d3c6bb347642f6489fbf896814cc6994 (patch)
tree3416019251bd11d1c0f22ec0e768551465cdcbc0 /community/monitoring-plugins
parent5945fa12c3090511b5afc66103a60745b82cc377 (diff)
downloadaports-f073ab96d3c6bb347642f6489fbf896814cc6994.tar.bz2
aports-f073ab96d3c6bb347642f6489fbf896814cc6994.tar.xz
community/monitoring-plugins: disable on all archs
bug in the configure script will fill up the buildservers disk https://github.com/monitoring-plugins/monitoring-plugins/issues/1480
Diffstat (limited to 'community/monitoring-plugins')
-rw-r--r--community/monitoring-plugins/APKBUILD22
-rw-r--r--community/monitoring-plugins/fix-perl.patch12
2 files changed, 24 insertions, 10 deletions
diff --git a/community/monitoring-plugins/APKBUILD b/community/monitoring-plugins/APKBUILD
index a2a32bee3e..d2e2384e2d 100644
--- a/community/monitoring-plugins/APKBUILD
+++ b/community/monitoring-plugins/APKBUILD
@@ -2,25 +2,28 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=monitoring-plugins
pkgver="2.2"
-pkgrel=0
+pkgrel=1
pkgdesc="Plugins for Icinga, Naemon, Nagios, Shinken, Sensu and other monitoring applications"
url="http://www.monitoring-plugins.org"
-arch="all !ppc64le"
+arch=""
license="GPL3"
depends=""
depends_dev=""
options="suid"
-makedepends="$depends_dev linux-headers libdbi-dev
- libressl-dev mariadb-dev postgresql-dev perl-dev "
+makedepends="$depends_dev linux-headers libdbi-dev
+ libressl-dev mariadb-dev postgresql-dev perl-dev
+ autoconf automake libtool"
install=""
subpackages="$pkgname-doc"
-source="https://www.monitoring-plugins.org/download/$pkgname-$pkgver.tar.gz"
+source="https://www.monitoring-plugins.org/download/$pkgname-$pkgver.tar.gz
+ fix-perl.patch"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare || return 1
update_config_guess || return 1
update_config_sub || return 1
+ autoreconf -vif
}
build() {
@@ -33,7 +36,7 @@ build() {
--with-pgsql \
--with-dbi \
--with-mysql \
- --with-ipv6
+ --with-ipv6
make || return 1
}
@@ -42,7 +45,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 LEGAL "$pkgdir"/usr/share/licenses/$pkgname/LEGAL
-
+
for i in ABOUT-NLS ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog \
FAQ NEWS README REQUIREMENTS SUPPORT THANKS; do
install -Dm644 $i "$pkgdir"/usr/share/doc/$pkgname/$i
@@ -50,6 +53,5 @@ package() {
rm $pkgdir/usr/lib/charset.alias
}
-md5sums="549e243ba1fb5c5b3be3a86961de40a7 monitoring-plugins-2.2.tar.gz"
-sha256sums="296a538f00a9cbef7f528ff2d43af357a44b384dc98a32389a675b62a6dd3665 monitoring-plugins-2.2.tar.gz"
-sha512sums="5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27 monitoring-plugins-2.2.tar.gz"
+sha512sums="5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27 monitoring-plugins-2.2.tar.gz
+1bc33fa6e7a0f2aa0648646e7e5118bd6d40c45c56ab0a0bdf4a7fb69c24353ddf5069d76923497ef37067afaa5d35ae5b5fc29a4f7622201a08efd83d1067ba fix-perl.patch"
diff --git a/community/monitoring-plugins/fix-perl.patch b/community/monitoring-plugins/fix-perl.patch
new file mode 100644
index 0000000000..bd24d92aac
--- /dev/null
+++ b/community/monitoring-plugins/fix-perl.patch
@@ -0,0 +1,12 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -120,6 +120,9 @@
+ ACX_HELP_STRING([--with-perl=PATH],
+ [sets path to perl executable]),
+ with_perl=$withval,with_perl=$PERL)
++if test "$with_perl" = "yes"; then
++ with_perl="$PERL"
++fi
+ AC_SUBST(PERL, $with_perl)
+
+ dnl openssl/gnutls