aboutsummaryrefslogtreecommitdiffstats
path: root/community/mpd
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-01-15 22:03:38 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-01-15 22:03:38 +0100
commit735d030db958d334d27bd3358574cf8978d1b75d (patch)
tree4982d58e53b20b5ebb0171a64b707dfec867347b /community/mpd
parent6b49c2098d96f6ec7872e48c465cb5f9828da4b1 (diff)
downloadaports-735d030db958d334d27bd3358574cf8978d1b75d.tar.bz2
aports-735d030db958d334d27bd3358574cf8978d1b75d.tar.xz
community/mpd: run checkpath with quiet flag
The checkpath invocation creates a directory usually located on a tmpfs and cleared on each boot. As such, mpd creates and "corrects" the permissions of this directory on each boot. This causes two unnecessary messages to be emitted on each boot by the service. This change adds the quiet flag which suppresses these messages.
Diffstat (limited to 'community/mpd')
-rw-r--r--community/mpd/APKBUILD4
-rw-r--r--community/mpd/mpd.initd3
2 files changed, 4 insertions, 3 deletions
diff --git a/community/mpd/APKBUILD b/community/mpd/APKBUILD
index 7921ebb8c5..6d85088a6b 100644
--- a/community/mpd/APKBUILD
+++ b/community/mpd/APKBUILD
@@ -9,7 +9,7 @@ case $pkgver in
*.*.*) _branch=${pkgver%.*};;
*.*) _branch=$pkgver;;
esac
-pkgrel=4
+pkgrel=5
pkgdesc="Music daemon that plays MP3, FLAC, Ogg Vorbis files and Audio CDs"
url="https://musicpd.org"
pkgusers="mpd"
@@ -79,7 +79,7 @@ package() {
sha512sums="68b4d9dc4be8454d7ef92df2a7b42513dc2d97bfd6b11ba99bce6709fc58ccbeab05419863bacb7a3427f1325bc88da74f9f4b48206222349085f02d0135e1a8 mpd-0.21.18.tar.xz
f60f6f3e921d20732c1a4c31a97f28660b43fd649e767d6c39661b6a90145231a79ad3f740ae0d706380b245ad040e98b661a513463c54cea161d1f64fc261e0 stacksize.patch
-1fcb7bcd90bd9bc5b4f502c56d1b0d3a3b794f5c3c1b26a2286a5936bc4e1f94f6317d52e54c958c23e40d69aa3e440535aec0fcbaaa73544ecd0c65ff6774a5 mpd.initd
+8547f685adf3cdc7b2aab7bedeed8c72242011c6f1e01750415ac21eba5ecf6b416239f527adbc904f72439c5d476249148cfb89965e33de1be69421e02c18e0 mpd.initd
41b2467f5b03f5c4dd7003cd5f56f6cfc1f67af7a9aa2538d70360f839625222bdd0c4b04c33e8cd52eeecfc354da3ca22f5aaab8aee357a5774aaf3503594e7 mpd.confd
94de2fb5e984e3246f79c2c7ab2f3123bba6c7d34e0f9b075ba3946d65912fd7f5e9d37bdb0bdee769fa6f6f8abb8ca5f2788b7976e2e5490b848800b31539fb disable-iso-test.patch
1e0e59247a22944435ca6052767ea1359d46362083de40ce36276327e4974315862a9f995f0047811e122bf4ce871f0b3965d15580f6a752d95c3617aa83136c libcdio-paranoia-version.patch"
diff --git a/community/mpd/mpd.initd b/community/mpd/mpd.initd
index 52d6ff4018..817583ca0a 100644
--- a/community/mpd/mpd.initd
+++ b/community/mpd/mpd.initd
@@ -20,5 +20,6 @@ depend() {
}
start_pre() {
- checkpath --directory --owner "${M_USER:-mpd}" --mode 0775 /var/run/mpd
+ checkpath --directory --quiet \
+ --owner "${M_USER:-mpd}" --mode 0775 /var/run/mpd
}