aboutsummaryrefslogtreecommitdiffstats
path: root/community/mpv
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-11-22 23:59:32 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-24 14:37:51 +0000
commitec6a8f09c8e1b6a4f2f0fbbe31c9817bcca30815 (patch)
treea5d4df5c3bb0a68a9ac5d48322f4be6129db69f0 /community/mpv
parent7f6a9eea926fa388fa60e0c90bc2a8da1d567d3b (diff)
downloadaports-ec6a8f09c8e1b6a4f2f0fbbe31c9817bcca30815.tar.bz2
aports-ec6a8f09c8e1b6a4f2f0fbbe31c9817bcca30815.tar.xz
community/mpv: compile with rsound support
This adds RSound support to mpv using librsound. This allows you to use the audio output from another computer on your network. This feature is similar to PluseAudios TCP module. Sending this to patchwork instead of committing it myself because it is rather uncommon to compile mpv with rsound support by default, however, it doesn't hurt and I find this feature very useful.
Diffstat (limited to 'community/mpv')
-rw-r--r--community/mpv/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/mpv/APKBUILD b/community/mpv/APKBUILD
index f81b1bfcf9..d4eceafad3 100644
--- a/community/mpv/APKBUILD
+++ b/community/mpv/APKBUILD
@@ -4,17 +4,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpv
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="Video player based on MPlayer/mplayer2"
url="http://mpv.io/"
arch="all"
license="GPL"
-depends=
+depends=""
makedepends="libxxf86dga-dev libxv-dev libmad-dev lame-dev libao-dev
libtheora-dev xvidcore-dev zlib-dev sdl-dev freetype-dev
x264-dev faac-dev ttf-dejavu libxvmc-dev alsa-lib-dev libva-dev
mesa-dev ffmpeg-dev libass-dev perl lua5.2-dev libvdpau-dev python
- libxext-dev libxscrnsaver-dev py-docutils"
+ libxext-dev libxscrnsaver-dev py-docutils rsound-dev"
install=""
subpackages="
$pkgname-doc
@@ -44,6 +44,7 @@ build() {
--enable-libass \
--enable-zsh-comp \
--enable-xss \
+ --enable-rsound \
|| return 1
./waf build || return 1
}