aboutsummaryrefslogtreecommitdiffstats
path: root/community/mumudvb
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 10:28:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 10:28:30 -0300
commit31f956427d7d12f147ea47da78d8da5a9918e502 (patch)
treeaf615cfe4537bf279c693fbc64d91f63e5541797 /community/mumudvb
parent64aa3d9c9702a261840ddebb424f31dab49fdab4 (diff)
downloadaports-31f956427d7d12f147ea47da78d8da5a9918e502.tar.bz2
aports-31f956427d7d12f147ea47da78d8da5a9918e502.tar.xz
community/mumudvb: fix url, fix license, disable
Diffstat (limited to 'community/mumudvb')
-rw-r--r--community/mumudvb/APKBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/community/mumudvb/APKBUILD b/community/mumudvb/APKBUILD
index 52ed4d00f2..3c916c1391 100644
--- a/community/mumudvb/APKBUILD
+++ b/community/mumudvb/APKBUILD
@@ -3,41 +3,42 @@
pkgname=mumudvb
_pkgname=MuMuDVB
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A DVB IPTV streaming software"
-url="https://mumudvb.net/"
-arch="all"
-license="GPL-2.0"
+url="http://mumudvb.net/"
+arch="" # Fails to build on kernels above 4.14
+license="GPL-2.0-or-later"
makedepends="automake autoconf libtool linux-headers m4 libdvbcsa-dev asciidoc gettext-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
pkgusers="mumudvb"
source="$pkgname-$pkgver.tar.gz::https://github.com/braice/MuMuDVB/archive/$pkgver.tar.gz
-0001-Fix-compiling-with-kernels-4.14.patch
-musl-error-h.patch
-$pkgname.initd
-$pkgname.confd"
+ 0001-Fix-compiling-with-kernels-4.14.patch
+ musl-error-h.patch
+ $pkgname.initd
+ $pkgname.confd"
builddir="$srcdir/$_pkgname-$pkgver"
-build() {
- cd "$builddir"
+prepare() {
libtoolize --force
aclocal && autoheader
automake --force-missing --add-missing
autoreconf -i -f
+}
+
+build() {
./configure --prefix=/usr
- make || return 1
+ make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/var/run/mumudvb
chown $pkgusers "$pkgdir"/var/run/mumudvb
install -m755 -D "$srcdir"/$pkgname.initd \
- "$pkgdir"/etc/init.d/$pkgname || return 1
+ "$pkgdir"/etc/init.d/$pkgname
install -m755 -D "$srcdir"/$pkgname.confd \
- "$pkgdir"/etc/conf.d/$pkgname || return 1
+ "$pkgdir"/etc/conf.d/$pkgname
mkdir -p "$pkgdir"/etc/$pkgname
}
@@ -46,7 +47,7 @@ doc() {
pkgdesc="$pkgname documentation"
_docdir="configuration_examples diagrams html transcode"
cd "$builddir"/doc
- make doc || return 1
+ make doc
mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
for doc in $_docdir; do
mv $doc "$subpkgdir"/usr/share/doc/$pkgname
@@ -56,5 +57,6 @@ doc() {
sha512sums="e300d0f9624a7a5d108ded303b11ef7f399968357540f681ae772efe2a36d32883c69f20e41f8372c0f9c39393c71f2eddb04c59bfadf71a0f575ea160a27cf2 mumudvb-2.1.0.tar.gz
05ba4f04f1a6f605c78ac142e19a410840a963169ace7d5180d25eba5627c4bcc2380c870a9e41d292839924ebf179af948a519d0f83ba475238e664c78d852d 0001-Fix-compiling-with-kernels-4.14.patch
83228d1ea51b892779d284e443477332f92bc27d5806294774ff6eb93c5b4896dbd04367559a03268aa9994f8555c748e82075e4b86b01866a65662bf5c00824 musl-error-h.patch
+de0ab5c7a7d570453cfe940c720aacf1104e04435d67cd0894806835f30778d5d9ee96686a6fa2739a1fc686fa51c933191ddae4b9c9714b6c4c719c22830444 kernel-4.14.patch
a59a282e04e72bb75e365f36dd4af7560826e8803f0ffa0244c59b2c88bf3e822d846358ababc74aa04de4758880a5bd53e02e3537b8ced0a23aea5360832709 mumudvb.initd
777096785f71f22e9b1462d8bd9a0dba39bda63fa9493d8431140cc09addfac6ce9f962c60aa50b6f331d8ecbaef8e1340cf401aa3caeb743d3a396326f28efa mumudvb.confd"