aboutsummaryrefslogtreecommitdiffstats
path: root/community/mutt
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-24 15:44:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-24 15:44:45 +0000
commit53b72f1f069768f6abd8e761aa93133812c858b5 (patch)
tree38336e63e2ce1cf661217b1a6ba82eb21fa40cd0 /community/mutt
parented115862c323b563d378a0ca48ef4f6e7cf55388 (diff)
downloadaports-53b72f1f069768f6abd8e761aa93133812c858b5.tar.bz2
aports-53b72f1f069768f6abd8e761aa93133812c858b5.tar.xz
main/mutt: move to community
Diffstat (limited to 'community/mutt')
-rw-r--r--community/mutt/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/mutt/APKBUILD b/community/mutt/APKBUILD
new file mode 100644
index 0000000000..684fe3f9d5
--- /dev/null
+++ b/community/mutt/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Andrew Manison <amanison@anselsystems.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mutt
+pkgver=1.10.1
+pkgrel=0
+pkgdesc="Small and very powerful text-mode email client"
+url="http://www.mutt.org"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="cyrus-sasl-dev gdbm-dev gettext-dev gpgme-dev
+ libidn-dev ncurses-dev libressl-dev perl"
+options="suid !check"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://bitbucket.org/$pkgname/$pkgname/downloads/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ISPELL=/usr/bin/hunspell \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-imap \
+ --enable-pop \
+ --enable-smtp \
+ --enable-hcache \
+ --enable-gpgme \
+ --enable-sidebar \
+ --with-curses \
+ --with-mailpath=/var/spool/mail \
+ --with-docdir=/usr/share/doc/$pkgname \
+ --without-included-gettext \
+ --with-ssl \
+ --with-sasl
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ rm -f "$pkgdir"/etc/*.dist \
+ "$pkgdir"/etc/mime.types
+
+ # Don't tamper with the global configuration file.
+ # Many options set in the global config cannot be
+ # overwritten in the users configuration file.
+ # Example: Resetting colors isn't possible.
+ install -Dm644 contrib/gpg.rc \
+ "$pkgdir"/etc/Muttrc.gpg.dist
+}
+
+sha512sums="13509ff159c65e23614696967b4bd8baf7b8e16c0e85cfd89e2df8201de2dc97e6c4a426f5919f05051dee2b14f847c7203e0b236931d3cdf81dbbb221551726 mutt-1.10.1.tar.gz"