aboutsummaryrefslogtreecommitdiffstats
path: root/community/mutter
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-10-10 15:34:06 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-10 15:35:07 +0200
commit943fbdf7d2e9bca01b3bb241a7be105d81505249 (patch)
tree83f4aa8d7bc3b812ef1f4259789dc8c5fab7be60 /community/mutter
parentb3a149326ffcd737040c59e6990ee95b86094819 (diff)
downloadaports-943fbdf7d2e9bca01b3bb241a7be105d81505249.tar.bz2
aports-943fbdf7d2e9bca01b3bb241a7be105d81505249.tar.xz
community/mutter: fix build on builders
The builders don't have a TTY, so adding /dev/stdout to test dependencies causes the reconfiguration to loop on them. Remove the faulty directory since we don't run mutter's tests anyway.
Diffstat (limited to 'community/mutter')
-rw-r--r--community/mutter/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/mutter/APKBUILD b/community/mutter/APKBUILD
index a88cb97906..4622ef9b9d 100644
--- a/community/mutter/APKBUILD
+++ b/community/mutter/APKBUILD
@@ -20,6 +20,13 @@ source="https://download.gnome.org/sources/mutter/${pkgver%.*}/mutter-$pkgver.ta
fix-cogl-path-build-ordering.patch
fixudev-req.patch"
+prepare() {
+ default_prepare
+ # disable unit test subdir, causes looping on builders and we don't run
+ # tests anyway
+ sed '/unit/d' -i cogl/tests/meson.build
+}
+
build() {
meson \
--prefix=/usr \
@@ -35,7 +42,7 @@ build() {
-Dremote_desktop=true \
-Dprofiler=false \
. output
- ninja -d explain -C output
+ ninja -C output
}
package() {