aboutsummaryrefslogtreecommitdiffstats
path: root/community/mythes
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-14 21:32:54 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-07-15 00:26:01 +0200
commit69bf70aaa381065ebaf40f9aee175c8a598bce77 (patch)
tree27e7b4dcd2c5cf502fb90adf128ed6a271872817 /community/mythes
parenta52a40744b6c1d63b6675cefe7e3cf26f23f77b0 (diff)
downloadaports-69bf70aaa381065ebaf40f9aee175c8a598bce77.tar.bz2
aports-69bf70aaa381065ebaf40f9aee175c8a598bce77.tar.xz
community/mythes: modernize APKBUILD
Diffstat (limited to 'community/mythes')
-rw-r--r--community/mythes/APKBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/community/mythes/APKBUILD b/community/mythes/APKBUILD
index fcd479d959..6dc45d2a49 100644
--- a/community/mythes/APKBUILD
+++ b/community/mythes/APKBUILD
@@ -8,38 +8,26 @@ url="http://hunspell.sourceforge.net/"
arch="all"
license="GPL2+ LGPL2+ MPL 1.1"
subpackages="$pkgname-dev"
-depends=""
depends_dev="perl hunspell-dev"
makedepends="$depends_dev"
-source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-static \
--disable-dependency-tracking \
- --enable-fast-install \
- || return 1
- make || return 1
+ --enable-fast-install
+ make
}
package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
}
dev() {
@@ -49,6 +37,4 @@ dev() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-md5sums="a8c2c5b8f09e7ede322d5c602ff6a4b6 mythes-1.2.4.tar.gz"
-sha256sums="1e81f395d8c851c3e4e75b568e20fa2fa549354e75ab397f9de4b0e0790a305f mythes-1.2.4.tar.gz"
sha512sums="a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21 mythes-1.2.4.tar.gz"