aboutsummaryrefslogtreecommitdiffstats
path: root/community/mythes
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 07:31:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commit972eff2662aab59fb4c708dca2c9b5475d8956b4 (patch)
tree96dd7dac448c26c69a7b736aad70cac34bccce13 /community/mythes
parent4355d82e16d88a3874dbaba2025f65542cefb4ce (diff)
downloadaports-972eff2662aab59fb4c708dca2c9b5475d8956b4.tar.bz2
aports-972eff2662aab59fb4c708dca2c9b5475d8956b4.tar.xz
community/mythes: moved from main
Diffstat (limited to 'community/mythes')
-rw-r--r--community/mythes/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/mythes/APKBUILD b/community/mythes/APKBUILD
new file mode 100644
index 0000000000..8fb9665821
--- /dev/null
+++ b/community/mythes/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=mythes
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="A simple thesaurus"
+url="http://hunspell.sourceforge.net/"
+arch="all"
+license="GPL2+ LGPL2+ MPL 1.1"
+subpackages="$pkgname-dev"
+depends=""
+depends_dev="perl hunspell-dev"
+makedepends="$depends_dev"
+source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+dev() {
+ default_dev
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="a8c2c5b8f09e7ede322d5c602ff6a4b6 mythes-1.2.4.tar.gz"
+sha256sums="1e81f395d8c851c3e4e75b568e20fa2fa549354e75ab397f9de4b0e0790a305f mythes-1.2.4.tar.gz"
+sha512sums="a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21 mythes-1.2.4.tar.gz"