aboutsummaryrefslogtreecommitdiffstats
path: root/community/nbd
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-17 23:57:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-18 13:54:25 -0300
commit3597d59de3e0e275f9b6b233f2b1af9ea5c53404 (patch)
tree38154401b2b3ea30141399e87f0325a864218f1e /community/nbd
parent13e34b665debd1dc2bc70ee533a05172f800a801 (diff)
downloadaports-3597d59de3e0e275f9b6b233f2b1af9ea5c53404.tar.bz2
aports-3597d59de3e0e275f9b6b233f2b1af9ea5c53404.tar.xz
community/nbd: upgrade to 3.19
Diffstat (limited to 'community/nbd')
-rw-r--r--community/nbd/APKBUILD14
-rw-r--r--community/nbd/nbd-server.initd3
2 files changed, 8 insertions, 9 deletions
diff --git a/community/nbd/APKBUILD b/community/nbd/APKBUILD
index 095629d2c8..fcc0f38005 100644
--- a/community/nbd/APKBUILD
+++ b/community/nbd/APKBUILD
@@ -1,23 +1,21 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=nbd
-pkgver=3.18
-pkgrel=1
+pkgver=3.19
+pkgrel=0
pkgdesc="Tools for network block devices"
url="http://nbd.sourceforge.net"
arch="all"
license="GPL-2.0-or-later"
makedepends="glib-dev linux-headers zlib-dev gnutls-dev libnl3-dev bash"
subpackages="$pkgname-doc $pkgname-client $pkgname-openrc"
-source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
+source="https://downloads.sourceforge.net/nbd/nbd-$pkgver.tar.xz
nbd-server.initd
fix-segfault-freeaddrinfo.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
CONFIG_SHELL=/bin/bash \
./configure \
--build=$CBUILD \
@@ -33,12 +31,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/nbd-server.initd \
"$pkgdir"/etc/init.d/nbd-server
@@ -52,6 +48,6 @@ client() {
"$subpkgdir"/usr/sbin/
}
-sha512sums="f9fe221b585c126efa3fb65e2344477a38f2ce42164b04d0dc4681c5a3bfd34d5d3e227454fff24eee9039853eb38a8707ea0aab0337f44906cccf379c185ce8 nbd-3.18.tar.xz
-3e71f0cd79d378abb1901038952748b548d18540aa7ebe94bcda65bc331021c1eef942c26283dbbd39471ecfa33c2c5b6165acfcf0abd7d17aed1bdcd47fea31 nbd-server.initd
+sha512sums="0916b411857045af6e01032b3093e295e7f3cfb1ae92f25adb03d97d3196741f8805104c627b17ad4f7f4305db3a4bcd5516bfd2c60fbea02b497dc296f97a16 nbd-3.19.tar.xz
+7012adb1d822454b29d1c75cdeaab9dfa2bf0e41c058509428227953b1e555b76c1802a78e66d8fa3fc2ada932cfe265e80c90fa9dbddd544c81b1411c8ab4b4 nbd-server.initd
fb83a0a1f2863b147f462e27edc713134a5a4541b5807dbb320cae67f96314ceca86c40b4cc344a6f0fd42e73a8807bf238edb3ebaeb2855eb98359b905855a3 fix-segfault-freeaddrinfo.patch"
diff --git a/community/nbd/nbd-server.initd b/community/nbd/nbd-server.initd
index b0cd32d4d1..6342e843c3 100644
--- a/community/nbd/nbd-server.initd
+++ b/community/nbd/nbd-server.initd
@@ -1,5 +1,8 @@
#!/sbin/openrc-run
+name="Network Block Device Server"
+description="Serve a block device as a file to other computers"
+
command=/usr/bin/nbd-server
pidfile=/run/nbd-server.pid
command_args="-p ${pidfile}"