aboutsummaryrefslogtreecommitdiffstats
path: root/community/ndctl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /community/ndctl
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'community/ndctl')
-rw-r--r--community/ndctl/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/ndctl/APKBUILD b/community/ndctl/APKBUILD
new file mode 100644
index 0000000000..34f91abad6
--- /dev/null
+++ b/community/ndctl/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=ndctl
+pkgver=67
+pkgrel=0
+pkgdesc="Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel"
+url="https://github.com/pmem/ndctl"
+arch="all"
+license="GPL-2.0-only LGPL-2.1-only"
+depends="libuuid json-c kmod"
+makedepends="autoconf automake libtool asciidoc xmlto kmod-dev
+ eudev-dev util-linux-dev json-c-dev linux-headers asciidoctor
+ bash-completion keyutils-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-libs
+ $pkgname-bash-completion:bashcomp:noarch"
+source="ndctl-$pkgver.tar.gz::https://github.com/pmem/ndctl/archive/v$pkgver.tar.gz"
+options="!check" # tests require building & loading the nfit_test.ko kernel module
+
+prepare() {
+ default_prepare
+ echo $pkgver >"$builddir/version"
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --without-systemd
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completion for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+}
+
+sha512sums="a923510468f540ac84fca5c562096b02eb3827c57e87ac36641f5ce129114ba583ce5ac5d71b45d7be876e880ad7e4fe38678350480d8974745120c7e0161435 ndctl-67.tar.gz"