aboutsummaryrefslogtreecommitdiffstats
path: root/community/neovim
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-20 23:27:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-24 15:50:26 -0300
commit43e5be00a032c5d47c7c7fd5826757179055bbc5 (patch)
tree2fdc827e2be392618a31559f80df9d6888c3657c /community/neovim
parent0442c7e27d38be07b6592c05642693b9edfd3434 (diff)
downloadaports-43e5be00a032c5d47c7c7fd5826757179055bbc5.tar.bz2
aports-43e5be00a032c5d47c7c7fd5826757179055bbc5.tar.xz
community/neovim: upgrade to 0.4.2
Diffstat (limited to 'community/neovim')
-rw-r--r--community/neovim/APKBUILD25
1 files changed, 6 insertions, 19 deletions
diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index 54f7541e7d..a237be4e4b 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -13,23 +13,16 @@
# TODO: Try to trim the base package to include only common syntax files etc.
pkgname=neovim
-pkgver=0.3.8
+pkgver=0.4.2
pkgrel=0
pkgdesc="Vim-fork focused on extensibility and agility"
url="https://neovim.io"
-# s390x: needs luajit
-arch="all !s390x"
+arch="all !aarch64 !s390x" # s390x|aarch64: needs luajit
license="Apache-2.0 custom"
makedepends="cmake gettext-dev gperf libtermkey-dev libuv-dev libvterm-dev
- lua5.1-lpeg lua5.1-mpack msgpack-c-dev unibilium-dev"
-# Build neovim with lua instead of luajit on aarch64
-# See https://github.com/neovim/neovim/issues/7879
-case "$CARCH" in
- aarch64) makedepends="$makedepends lua5.1-dev lua5.1-bitop" ;;
- *) makedepends="$makedepends luajit-dev" ;;
-esac
+ lua5.1-lpeg lua5.1-mpack msgpack-c-dev unibilium-dev luajit-dev libluv-dev"
subpackages="$pkgname-lang $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/$pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/neovim/archive/v$pkgver.tar.gz
nodoc.txt
"
@@ -37,18 +30,12 @@ build() {
mkdir -p "$builddir"/build
cd "$builddir"/build
- local cmakeoptions=
- case "$CARCH" in
- aarch64) cmakeoptions="-DPREFER_LUA=ON" ;;
- esac
-
cmake .. \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_JEMALLOC=FALSE \
- -DCMAKE_VERBOSE_MAKEFILE=TRUE \
- $cmakeoptions
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE
make
}
@@ -76,5 +63,5 @@ doc() {
done
}
-sha512sums="431d3df859b430570e3f927328b862945a15b1ac041108599670d32af6cccac9361a143fc6af27847529629a43a5e0a0afd98b1c826d4ee1e7570de3cf14f9c7 neovim-0.3.8.tar.gz
+sha512sums="cc0de18ee7ca5105a0dd9f5f06b4d58335618b22c4dc3d584a024683785ff9d541c7f5131742b8a818ac9acb2218da92f9b8a881d56c4b963237918e589fac22 neovim-0.4.2.tar.gz
72ab288f53acddc088c567aafe8c5afa6835325fab7879e782d1d62f87a662f3a6bac123c450debbae1b32336cc60b2830b429838ee3dfcc7524773b5069f4f0 nodoc.txt"