aboutsummaryrefslogtreecommitdiffstats
path: root/community/neovim
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2019-11-24 13:27:40 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-24 18:06:55 +0100
commitd75cdc680db8a366e6af42c1a0c4378db60eeead (patch)
tree7b86d572274b7546c92c21bcc7639083d0e0cad0 /community/neovim
parent6256b22db6d8da835fd3b889e8dbf43b278e0433 (diff)
downloadaports-d75cdc680db8a366e6af42c1a0c4378db60eeead.tar.bz2
aports-d75cdc680db8a366e6af42c1a0c4378db60eeead.tar.xz
community/neovim: enable aarch64
Diffstat (limited to 'community/neovim')
-rw-r--r--community/neovim/APKBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index ad31fec88c..9bbcf7b7a4 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -14,13 +14,19 @@
# TODO: Try to trim the base package to include only common syntax files etc.
pkgname=neovim
pkgver=0.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="Vim-fork focused on extensibility and agility"
url="https://neovim.io"
-arch="all !aarch64 !s390x" # s390x|aarch64: needs luajit
+arch="all !s390x" # s390x: needs luajit
license="Apache-2.0 custom"
makedepends="cmake gettext-dev gperf libtermkey-dev libuv-dev libvterm-dev
- lua5.1-lpeg lua5.1-mpack msgpack-c-dev unibilium-dev luajit-dev libluv-dev"
+ lua5.1-lpeg lua5.1-mpack msgpack-c-dev unibilium-dev libluv-dev"
+# Build neovim with lua instead of luajit on aarch64
+# See https://github.com/neovim/neovim/issues/7879
+case "$CARCH" in
+ aarch64) makedepends="$makedepends lua5.1-dev lua5.1-bitop" ;;
+ *) makedepends="$makedepends luajit-dev" ;;
+esac
subpackages="$pkgname-lang $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/neovim/archive/v$pkgver.tar.gz
nodoc.txt
@@ -30,12 +36,18 @@ build() {
mkdir -p "$builddir"/build
cd "$builddir"/build
+ local cmakeoptions=
+ case "$CARCH" in
+ aarch64) cmakeoptions="-DPREFER_LUA=ON" ;;
+ esac
+
cmake .. \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_JEMALLOC=FALSE \
- -DCMAKE_VERBOSE_MAKEFILE=TRUE
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE \
+ $cmakeoptions
make
}