aboutsummaryrefslogtreecommitdiffstats
path: root/community/neovim
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-04-27 16:45:32 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-28 22:44:53 +0200
commitdc7a75d3f3cb957fb4afb19888369f8e9ac45380 (patch)
tree9aaa393958bc06cb26b334e6942a7035d2603555 /community/neovim
parent59f5440e1a3686924927f792c9f81bcd6ec39dfc (diff)
downloadaports-dc7a75d3f3cb957fb4afb19888369f8e9ac45380.tar.bz2
aports-dc7a75d3f3cb957fb4afb19888369f8e9ac45380.tar.xz
community/neovim: modernize abuild
Diffstat (limited to 'community/neovim')
-rw-r--r--community/neovim/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index 7811315fbb..8ee1d532fc 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -24,7 +24,8 @@ makedepends="cmake gettext-dev gperf libtermkey-dev libuv-dev libvterm-dev
subpackages="$pkgname-lang $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/$pkgname/archive/v$pkgver.tar.gz
ignore-st-cursor-shape.patch
- nodoc.txt"
+ nodoc.txt
+ "
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -36,9 +37,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_JEMALLOC=FALSE \
- -DCMAKE_VERBOSE_MAKEFILE=TRUE \
- || return 1
- make || return 1
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE
+ make
}
package() {
@@ -47,21 +47,21 @@ package() {
}
doc() {
- default_doc || return 1
+ default_doc
pkgdesc="$pkgdesc (documentation and help pages)"
replaces="$pkgname"
local docdir="usr/share/nvim/runtime/doc"
mkdir -p "$subpkgdir"/$docdir
- mv "$pkgdir"/$docdir/*.txt "$subpkgdir"/$docdir/ || return 1
+ mv "$pkgdir"/$docdir/*.txt "$subpkgdir"/$docdir/
# When user execute ":help <pattern>", neovim will open nodoc.txt
# with information why docs are not available and how to install them.
install -D "$srcdir"/nodoc.txt \
- "$pkgdir"/$docdir/nodoc.txt || return 1
+ "$pkgdir"/$docdir/nodoc.txt
local f; for f in "$subpkgdir"/$docdir/*.txt; do
- ln -s nodoc.txt "$pkgdir"/$docdir/$(basename $f) || return 1
+ ln -s nodoc.txt "$pkgdir"/$docdir/$(basename $f)
done
}