aboutsummaryrefslogtreecommitdiffstats
path: root/community/nethack/APKBUILD
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-08-20 15:25:08 +0900
committerLeo <thinkabit.ukim@gmail.com>2019-08-20 13:01:06 -0300
commit4e9eae6dc95ef10786fd6f4207a87b4f658eed28 (patch)
treee9adc037abaee39ee982658f7c9a5446de3e0891 /community/nethack/APKBUILD
parentdd9a023599e4a3572ae0a37a49d664bc470cf4f0 (diff)
downloadaports-4e9eae6dc95ef10786fd6f4207a87b4f658eed28.tar.bz2
aports-4e9eae6dc95ef10786fd6f4207a87b4f658eed28.tar.xz
community/nethack: move from testing
Diffstat (limited to 'community/nethack/APKBUILD')
-rw-r--r--community/nethack/APKBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/community/nethack/APKBUILD b/community/nethack/APKBUILD
new file mode 100644
index 0000000000..cca2f741d4
--- /dev/null
+++ b/community/nethack/APKBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Based on the Arch Linux package
+pkgname=nethack
+pkgver=3.6.1
+pkgrel=0
+pkgdesc="A single player dungeon exploration game"
+url="https://www.nethack.org/index.html"
+arch="all"
+license="NGPL"
+makedepends="ncurses-dev linux-headers bison flex"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-${pkgver//.}-src.tgz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="suid"
+
+prepare() {
+ cd "$builddir"
+ # Fix nonstandard cp usage
+ sed -e 's/cp -n/cp/g' -i sys/unix/hints/linux
+ # Configuration stuff
+ sed -e 's|^/\* \(#define LINUX\) \*/|\1|' \
+ -e 's|^/\* \(#define TIMED_DELAY\) \*/|\1|' \
+ -i include/unixconf.h
+ # we are setting up for setgid games, so modify all necessary permissions
+ # to allow full access for groups
+ sed -e '/^HACKDIR/ s|/games/lib/\$(GAME)dir|/var/games/nethack/|' \
+ -e '/^SHELLDIR/ s|/games|/usr/bin|' \
+ -e '/^VARDIRPERM/ s|0755|0775|' \
+ -e '/^VARFILEPERM/ s|0600|0664|' \
+ -e '/^GAMEPERM/ s|0755|02755|' \
+ -e 's|\(DSYSCF_FILE=\)\\"[^"]*\\"|\1\\"/var/games/nethack/sysconf\\"|' \
+ -e 's|\(DHACKDIR=\)\\"[^"]*\\"|\1\\"/var/games/nethack/\\"|' \
+ -i sys/unix/hints/linux
+ sed -e 's|^#GAMEUID.*|GAMEUID = root|' \
+ -e 's|^#GAMEGRP.*|GAMEGRP = games|' \
+ -e '/^FILEPERM\s*=/ s|0644|0664|' \
+ -e '/^DIRPERM\s*=/ s|0755|0775|' \
+ -i sys/unix/Makefile.top
+ sed -e "/^MANDIR\s*=/s|/usr/man/man6|$pkgdir/usr/share/man/man6|" \
+ -i sys/unix/Makefile.doc
+}
+
+build() {
+ cd "$builddir"/sys/unix
+ sh setup.sh hints/linux
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ NETHACKDIR=/tmp ./src/nethack --version
+}
+
+package() {
+ cd "$builddir"
+ install -dm755 $pkgdir/usr/share/man/man6
+ install -dm755 $pkgdir/usr/share/doc/nethack
+ install -dm775 $pkgdir/var/games/
+ make PREFIX=$pkgdir -j1 install manpages # Multi-threaded builds fail.
+ sed -e "s|HACKDIR=$pkgdir/|HACKDIR=/|" \
+ -e 's|HACK=$HACKDIR|HACK=/usr/lib/nethack|' \
+ -i $pkgdir/usr/bin/nethack
+
+ install -dm755 $pkgdir/usr/lib/nethack
+ mv $pkgdir/var/games/nethack/nethack $pkgdir/usr/lib/nethack/
+ mv $pkgdir/var/games/nethack/recover $pkgdir/usr/lib/nethack/
+
+ chown -R root:games $pkgdir/var/games/
+ chown root:games $pkgdir/usr/lib/nethack/nethack
+
+ install -Dm644 doc/Guidebook.txt $pkgdir/usr/share/doc/nethack/Guidebook.txt
+}
+sha512sums="bd6e36c163f0d85e1ab1fc659464696b5a02c3864a800ad47e047fdc4a35fff4ef7dd28a9b071fa46f7f67fa45c97fdc77bc1f2bdbad80cc02950d73731d9c30 nethack-361-src.tgz"