aboutsummaryrefslogtreecommitdiffstats
path: root/community/networkmanager
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 20:08:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 21:20:40 -0300
commit620178229e6e78741a63c96f495a48247f44e488 (patch)
tree71d25576b4e5d3d6f231813978a2c610f697736b /community/networkmanager
parent5f77150ab6ff54d6897006bf52ae9685ed41d884 (diff)
downloadaports-620178229e6e78741a63c96f495a48247f44e488.tar.bz2
aports-620178229e6e78741a63c96f495a48247f44e488.tar.xz
community/networkmanager: drop python2
Diffstat (limited to 'community/networkmanager')
-rw-r--r--community/networkmanager/APKBUILD6
-rw-r--r--community/networkmanager/py3.patch351
2 files changed, 355 insertions, 2 deletions
diff --git a/community/networkmanager/APKBUILD b/community/networkmanager/APKBUILD
index 1344094a5b..9fab119220 100644
--- a/community/networkmanager/APKBUILD
+++ b/community/networkmanager/APKBUILD
@@ -34,7 +34,7 @@ makedepends="$depends_dev
meson
py-gobject3
libpsl-dev
- python2
+ python3
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-openrc"
source="https://download.gnome.org/sources/NetworkManager/${pkgver:0:4}/NetworkManager-$pkgver.tar.xz
@@ -49,6 +49,7 @@ source="https://download.gnome.org/sources/NetworkManager/${pkgver:0:4}/NetworkM
musl-compar.patch
fix-ppc64le-build.patch
musl-no-drand.patch
+ py3.patch
"
options="!check" # fail to compile on musl
@@ -119,4 +120,5 @@ b5cd94928ca3ba1fb71aec28d9ff66f319f6d23131e02c90f1dfbfaf16c537935228a9981c95f29f
76b6728389686c91df6acafbbe17af7f0e01971e5f7185e164dcb39f93982ac6b73fc2cdf0ba2018e3fa80321178621fe2a5d910546de98bfc52484aa5d90d34 musl-has-not-secure-getenv.patch
634377674691b52da80ca4c445a727d39cd40269f7deef0d3ccc1e1041cc262e8bc1423200e9a2b0cf1804e9950059ebbbc827f1200c6a97c58bc76080a6d6d2 musl-compar.patch
c2dbdf31adb472dc6b14aad6d7a0981b2618880df7c9081ebb9bc6da8af4c5e791c36c4e997878d5e1e7f96bd65814f718e7ae23dcfea5ac5aa91acdab3775ae fix-ppc64le-build.patch
-342fb3eef0e7057b6d8f1a00687af17dc633387d8a25d475e3e9c8de5712221eec8ada634a189e3458dcbb12b20625b99b552acda3927b5baa61b960ce5740eb musl-no-drand.patch"
+342fb3eef0e7057b6d8f1a00687af17dc633387d8a25d475e3e9c8de5712221eec8ada634a189e3458dcbb12b20625b99b552acda3927b5baa61b960ce5740eb musl-no-drand.patch
+b79a8d9581e843eeb0d773b2ba53f7a8081a788143f9684280f436d8797e7ca1af2e878300e1388f43f60fba3e25358de4245426b80c3d9b001679a72cf37b03 py3.patch"
diff --git a/community/networkmanager/py3.patch b/community/networkmanager/py3.patch
new file mode 100644
index 0000000000..adf9eacf5f
--- /dev/null
+++ b/community/networkmanager/py3.patch
@@ -0,0 +1,351 @@
+diff --git a/clients/tests/test-client.py b/clients/tests/test-client.py
+index ff5a360..0e25df1 100755
+--- a/clients/tests/test-client.py
++++ b/clients/tests/test-client.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from __future__ import print_function
+
+diff --git a/examples/python/dbus/add-connection-compat.py b/examples/python/dbus/add-connection-compat.py
+index 8806fca..6588267 100755
+--- a/examples/python/dbus/add-connection-compat.py
++++ b/examples/python/dbus/add-connection-compat.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/add-connection.py b/examples/python/dbus/add-connection.py
+index 510f7c8..8d5151e 100755
+--- a/examples/python/dbus/add-connection.py
++++ b/examples/python/dbus/add-connection.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/add-wifi-eap-connection.py b/examples/python/dbus/add-wifi-eap-connection.py
+index e8ce6df..eae37bd 100755
+--- a/examples/python/dbus/add-wifi-eap-connection.py
++++ b/examples/python/dbus/add-wifi-eap-connection.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/add-wifi-psk-connection.py b/examples/python/dbus/add-wifi-psk-connection.py
+index d8268b1..a590b6c 100755
+--- a/examples/python/dbus/add-wifi-psk-connection.py
++++ b/examples/python/dbus/add-wifi-psk-connection.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/create-bond.py b/examples/python/dbus/create-bond.py
+index 4347b2a..2451107 100755
+--- a/examples/python/dbus/create-bond.py
++++ b/examples/python/dbus/create-bond.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/disconnect-device.py b/examples/python/dbus/disconnect-device.py
+index e884df6..754197e 100755
+--- a/examples/python/dbus/disconnect-device.py
++++ b/examples/python/dbus/disconnect-device.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/get-active-connection-uuids.py b/examples/python/dbus/get-active-connection-uuids.py
+index 6e4310d..910dbc8 100755
+--- a/examples/python/dbus/get-active-connection-uuids.py
++++ b/examples/python/dbus/get-active-connection-uuids.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/is-wwan-default.py b/examples/python/dbus/is-wwan-default.py
+index c16aadc..d0c7918 100755
+--- a/examples/python/dbus/is-wwan-default.py
++++ b/examples/python/dbus/is-wwan-default.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/list-connections.py b/examples/python/dbus/list-connections.py
+index 90aec3b..45f8fc5 100755
+--- a/examples/python/dbus/list-connections.py
++++ b/examples/python/dbus/list-connections.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/list-devices.py b/examples/python/dbus/list-devices.py
+index fd58695..b1c853a 100755
+--- a/examples/python/dbus/list-devices.py
++++ b/examples/python/dbus/list-devices.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/nm-state.py b/examples/python/dbus/nm-state.py
+index 68979ef..3ca9764 100755
+--- a/examples/python/dbus/nm-state.py
++++ b/examples/python/dbus/nm-state.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/show-bssids.py b/examples/python/dbus/show-bssids.py
+index b364ed0..7c4294e 100755
+--- a/examples/python/dbus/show-bssids.py
++++ b/examples/python/dbus/show-bssids.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/update-ip4-method.py b/examples/python/dbus/update-ip4-method.py
+index 5a1cd4c..97436db 100755
+--- a/examples/python/dbus/update-ip4-method.py
++++ b/examples/python/dbus/update-ip4-method.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/update-secrets.py b/examples/python/dbus/update-secrets.py
+index 1fc7320..6d3801a 100755
+--- a/examples/python/dbus/update-secrets.py
++++ b/examples/python/dbus/update-secrets.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/vpn.py b/examples/python/dbus/vpn.py
+index 0c4b2bb..dc3ef48 100755
+--- a/examples/python/dbus/vpn.py
++++ b/examples/python/dbus/vpn.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/wifi-active-ap.py b/examples/python/dbus/wifi-active-ap.py
+index c0ed671..fa8f829 100755
+--- a/examples/python/dbus/wifi-active-ap.py
++++ b/examples/python/dbus/wifi-active-ap.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/dbus/wifi-hotspot.py b/examples/python/dbus/wifi-hotspot.py
+index 9b057a2..9378cde 100755
+--- a/examples/python/dbus/wifi-hotspot.py
++++ b/examples/python/dbus/wifi-hotspot.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/add_connection.py b/examples/python/gi/add_connection.py
+index 3b0abef..eac7977 100755
+--- a/examples/python/gi/add_connection.py
++++ b/examples/python/gi/add_connection.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/deactivate-all.py b/examples/python/gi/deactivate-all.py
+index 7a9b2ce..2a4906c 100755
+--- a/examples/python/gi/deactivate-all.py
++++ b/examples/python/gi/deactivate-all.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/device-state-ip4config.py b/examples/python/gi/device-state-ip4config.py
+index 70ab887..98b8862 100755
+--- a/examples/python/gi/device-state-ip4config.py
++++ b/examples/python/gi/device-state-ip4config.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/firewall-zone.py b/examples/python/gi/firewall-zone.py
+index 6be18dd..260c465 100755
+--- a/examples/python/gi/firewall-zone.py
++++ b/examples/python/gi/firewall-zone.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/get-active-connections.py b/examples/python/gi/get-active-connections.py
+index d7d3566..56d2c21 100755
+--- a/examples/python/gi/get-active-connections.py
++++ b/examples/python/gi/get-active-connections.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/get_ips.py b/examples/python/gi/get_ips.py
+index 48bbac6..2b82e7e 100755
+--- a/examples/python/gi/get_ips.py
++++ b/examples/python/gi/get_ips.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/list-connections.py b/examples/python/gi/list-connections.py
+index 4cd15fe..c1d0403 100755
+--- a/examples/python/gi/list-connections.py
++++ b/examples/python/gi/list-connections.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/nm-add-connection2.py b/examples/python/gi/nm-add-connection2.py
+index b78016d..2d0c0a1 100755
+--- a/examples/python/gi/nm-add-connection2.py
++++ b/examples/python/gi/nm-add-connection2.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/nm-connection-update-stable-id.py b/examples/python/gi/nm-connection-update-stable-id.py
+index bd4f12b..f4a18d2 100755
+--- a/examples/python/gi/nm-connection-update-stable-id.py
++++ b/examples/python/gi/nm-connection-update-stable-id.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/nm-update2.py b/examples/python/gi/nm-update2.py
+index 36449fd..f990769 100755
+--- a/examples/python/gi/nm-update2.py
++++ b/examples/python/gi/nm-update2.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/nm-wg-set b/examples/python/gi/nm-wg-set
+index 5f284c2..d9db2f8 100755
+--- a/examples/python/gi/nm-wg-set
++++ b/examples/python/gi/nm-wg-set
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/examples/python/gi/setting-user-data.py b/examples/python/gi/setting-user-data.py
+index d5e0010..db3b9a1 100755
+--- a/examples/python/gi/setting-user-data.py
++++ b/examples/python/gi/setting-user-data.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/show-wifi-networks.py b/examples/python/gi/show-wifi-networks.py
+index 6eb6ac9..0308bd2 100755
+--- a/examples/python/gi/show-wifi-networks.py
++++ b/examples/python/gi/show-wifi-networks.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # coding=utf-8
+ #
+ # This program is free software; you can redistribute it and/or modify
+diff --git a/examples/python/gi/update-ip4-method.py b/examples/python/gi/update-ip4-method.py
+index e4c603f..4cb742f 100755
+--- a/examples/python/gi/update-ip4-method.py
++++ b/examples/python/gi/update-ip4-method.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+diff --git a/libnm/generate-setting-docs.py b/libnm/generate-setting-docs.py
+index 7e89007..f5d31c2 100755
+--- a/libnm/generate-setting-docs.py
++++ b/libnm/generate-setting-docs.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # This library is free software; you can redistribute it and/or
+ # modify it under the terms of the GNU Lesser General Public
+ # License as published by the Free Software Foundation; either
+diff --git a/src/tests/test-secret-agent.py b/src/tests/test-secret-agent.py
+index d8cabc6..5f0ed5e 100755
+--- a/src/tests/test-secret-agent.py
++++ b/src/tests/test-secret-agent.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from gi.repository import GLib
+ import sys
+diff --git a/tools/test-networkmanager-service.py b/tools/test-networkmanager-service.py
+index c921aed..030546f 100755
+--- a/tools/test-networkmanager-service.py
++++ b/tools/test-networkmanager-service.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from __future__ import print_function
+
+