aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud-client/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-20 21:21:14 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-06-24 06:11:35 +0000
commitb319095697fe54b56031a53b5e6fb6d2515d5e3c (patch)
treefa6bee51da553c7c030de46d8251654d2353352d /community/nextcloud-client/APKBUILD
parentf58f9faef15026ebfef8c258be8fdf2f88767e37 (diff)
downloadaports-b319095697fe54b56031a53b5e6fb6d2515d5e3c.tar.bz2
aports-b319095697fe54b56031a53b5e6fb6d2515d5e3c.tar.xz
community/nextcloud-client: re-enable all architectures, modernize
Also remove qt5-qtwebengine as it's broken right now
Diffstat (limited to 'community/nextcloud-client/APKBUILD')
-rw-r--r--community/nextcloud-client/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/nextcloud-client/APKBUILD b/community/nextcloud-client/APKBUILD
index b5c369dfbc..49a0e06cca 100644
--- a/community/nextcloud-client/APKBUILD
+++ b/community/nextcloud-client/APKBUILD
@@ -1,22 +1,22 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=nextcloud-client
pkgver=2.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="Nextcloud Desktop Client"
-url="https://github.com/nextcloud/client_theming"
-arch="all !x86 !s390x !ppc64le" # qt5-qtwebengine not avail
+url="https://github.com/nextcloud/desktop"
+arch="all"
license="GPL-2.0-only"
-makedepends="$depends_dev cmake doxygen qt5-qtwebengine-dev qt5-qttools-dev
+makedepends="$depends_dev cmake doxygen qt5-qttools-dev
qt5-qtwebkit-dev qt5-qtkeychain-dev"
subpackages="$pkgname-dev"
options="!check" # no testsuite
-source="nextcloud-client.tar.gz::https://github.com/nextcloud/desktop/archive/v$pkgver.tar.gz"
+source="nextcloud-client.tar.gz::https://github.com/nextcloud/desktop/archive/v$pkgver.tar.gz
+ remove-qtwebengine.patch"
builddir="$srcdir"/desktop-$pkgver
build() {
- cd "$builddir"
cmake \
- -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_SYSCONFDIR=/etc/$pkgname
@@ -24,8 +24,8 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="1000b420355d7a4104ca5b41e813d467dcb345b60c79c78ce532de9c58ea89cad10d5565a433409bd512f0f7771c18c7c27974b968c74f84ccfda1ed3510d3ae nextcloud-client.tar.gz"
+sha512sums="1000b420355d7a4104ca5b41e813d467dcb345b60c79c78ce532de9c58ea89cad10d5565a433409bd512f0f7771c18c7c27974b968c74f84ccfda1ed3510d3ae nextcloud-client.tar.gz
+17e6a8437d33a2bb1305e45405aee4e23f233e00c232669a1f8317355032d88329899d3f7b65d1069cf1612029b589a575b0f64018b9b23d239a73c5f4bed2ce remove-qtwebengine.patch"