aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-27 13:23:57 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-27 14:10:03 +0100
commit308944d90df71c773c958a1c5ff4ebdb240526a3 (patch)
tree88f1668824f4f80c5d21c31e954d9f847144c1d9 /community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
parent7d73d222fd7122c6881d333ea7d07fc500596495 (diff)
downloadaports-308944d90df71c773c958a1c5ff4ebdb240526a3.tar.bz2
aports-308944d90df71c773c958a1c5ff4ebdb240526a3.tar.xz
main/nodejs: rename to nodejs-current and move to community
Odd-numbered versions, like this one (v7), are supported by upstream only for 9 months. When a new odd-numbered major release is cut, the previous even-numbered major version transitions to the Long Term Support plan (LTS). Packages in Alpine stable must be supported for 2 years, so we should keep only LTS version in the stable. Therefore this package is renamed to nodejs-current and moved to the community repository. The nodejs-lts package is going to be renamed to nodejs. See https://github.com/nodejs/LTS#lts-schedule
Diffstat (limited to 'community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch')
-rw-r--r--community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
new file mode 100644
index 0000000000..ba521dc4fc
--- /dev/null
+++ b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
@@ -0,0 +1,21 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Sat, 26 Nov 2016 01:32:00 +0200
+Subject: Disable running gyp files for bundled deps
+
+Author: Stephen Gallagher <sgallagh@redhat.com>
+
+Modified 2016-11-26 by Jakub Jirutka <jakub@jirutka.cz> to update for
+Node.js 7.2.0
+
+--- a/Makefile
++++ b/Makefile
+@@ -72,8 +72,7 @@
+ $(MAKE) -C out BUILDTYPE=Debug V=$(V)
+ ln -fs out/Debug/$(NODE_EXE) $@
+
+-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
+- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
++out/Makefile: common.gypi deps/v8/gypfiles/toolchain.gypi \
+ deps/v8/gypfiles/features.gypi deps/v8/src/v8.gyp node.gyp \
+ config.gypi
+ $(PYTHON) tools/gyp_node.py -f make