aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-10-25 18:10:33 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-11-03 02:02:28 +0200
commit13f69e36c8621e039fa69fa14701fffe6c651915 (patch)
tree17e255e658a70116fe85a694664eb163ea36a416 /community/nodejs-current
parent38693c8a17854105add7b52e2ed4bae410f59956 (diff)
downloadaports-13f69e36c8621e039fa69fa14701fffe6c651915.tar.bz2
aports-13f69e36c8621e039fa69fa14701fffe6c651915.tar.xz
community/nodejs-current: upgrade to 13.0.1
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD7
-rw-r--r--community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch4
2 files changed, 5 insertions, 6 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 018b22ef58..d0f7e6c44d 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -20,7 +20,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=12.12.0
+pkgver=13.0.1
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -58,7 +58,6 @@ build() {
--shared-zlib \
--shared-libuv \
--shared-openssl \
- --experimental-http-parser \
--shared-cares \
--shared-nghttp2 \
--openssl-use-def-ca-store
@@ -93,6 +92,6 @@ package() {
rm "$pkgdir"/usr/bin/npm "$pkgdir"/usr/bin/npx
}
-sha512sums="73bbf98fa747ebb350b89ab74843b3528950f50947675bbd9d403dc909dc857964ae8bbec8f4517bf719a596b2e3f5b95ffcd2616265e15188638a9939318b9f node-v12.12.0.tar.gz
-3c536776e2ecb5dc677bf711a09418085b3c5e931a6eaf647f47c28e194d5c6dec354d4e7a039a5805b30fc7e83140594851e18d9120f523eec2f93539eac4db dont-run-gyp-files-for-bundled-deps.patch
+sha512sums="43c91752e3dd4e30d4c007d79cc135c9d4d4ae05f04d8d3f649965910822d302865fae02f56f2f334bbf306937f17b7e1161eef684163671c6f9e52fbe19c16b node-v13.0.1.tar.gz
+940cc90aaa77a531cde13e31918a9978f9478936c3851038bcdf2869e64de03ce84dec5a46519469a90a8ba2853226825452d23d9347752abdbe04e944c083eb dont-run-gyp-files-for-bundled-deps.patch
9f60928b53447f9590c7065bcdbdd4065d10a06e8451531615791a3bd7d14f9114807e5446e0ec00e2cb7a11a277050345e34636b199db2979d7f022b31ffde4 link-with-libatomic-on-mips32.patch"
diff --git a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
index db2ab01c66..35a0153353 100644
--- a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
+++ b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
@@ -13,8 +13,8 @@ Node.js 7.2.0
echo "'test-code-cache' target is a noop"
out/Makefile: config.gypi common.gypi node.gyp \
-- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
-+ deps/http_parser/http_parser.gyp \
+- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
++ deps/llhttp/llhttp.gyp \
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
$(PYTHON) tools/gyp_node.py -f make