aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-01-15 05:18:12 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 10:53:08 +0000
commitad82366bf2488a0ebdd78def6a9a9f354c6e6b80 (patch)
treef1fbb8334b24beabc439a72e3a5cae0e097bc219 /community/nodejs-current
parent6805947f65a41af8b0137a1bc5eaddc2ae06cd3e (diff)
downloadaports-ad82366bf2488a0ebdd78def6a9a9f354c6e6b80.tar.bz2
aports-ad82366bf2488a0ebdd78def6a9a9f354c6e6b80.tar.xz
community/nodejs-current: upgrade to 11.6.0
- build against system libnghttp2.so (which upstream bundles/uses since 8.x); - switch to bundled http_parser due to build failure and make the experimental bundled llhttp (claimed to be 2x faster) default. - remove binutils-gold from makedepends, it is not needed; - remove ca-certificates from makedepends, it seems the run-time dependency is enough.
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD16
-rw-r--r--community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch13
2 files changed, 13 insertions, 16 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index f68603bd51..c5a4e5835e 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -18,7 +18,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=11.3.0
+pkgver=11.6.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -26,9 +26,8 @@ arch="all !mips64 !mips64el"
license="MIT"
depends="ca-certificates"
depends_dev="libuv"
-# gold is needed for mksnapshot
-makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev linux-headers
- paxmark binutils-gold http-parser-dev ca-certificates c-ares-dev"
+makedepends="linux-headers python2 paxmark
+ zlib-dev libuv-dev openssl-dev c-ares-dev nghttp2-dev"
subpackages="$pkgname-dev $pkgname-doc"
provides="nodejs"
replaces="nodejs nodejs-lts" # nodejs-lts for backward compatibility
@@ -42,7 +41,7 @@ prepare() {
default_prepare
# Remove bundled dependencies that we're not using.
- rm -rf deps/http_parser deps/openssl deps/uv deps/zlib
+ rm -rf deps/cares deps/openssl deps/uv deps/zlib
}
build() {
@@ -57,8 +56,9 @@ build() {
--shared-zlib \
--shared-libuv \
--shared-openssl \
- --shared-http-parser \
+ --experimental-http-parser \
--shared-cares \
+ --shared-nghttp2 \
--openssl-use-def-ca-store
# we need run mksnapshot at build time so paxmark it early.
@@ -91,6 +91,6 @@ package() {
rm "$pkgdir"/usr/bin/npm "$pkgdir"/usr/bin/npx
}
-sha512sums="dd1475bd61dbc2aac563e12ced0b9423bf1f5fc421d0699526799b60254d89cbb8d01530f2f029fe146777aecadc4aa54ad62d7b33fb9195f16d8a54b1278588 node-v11.3.0.tar.gz
-9145a28bc3c2ebfc5e29e7416f8387a68808607eea4d87830a14a27c80628177a02ef4ed54b0efe2384c39fedf7356d12c267567d06d53d669c55d6211bfcf8a dont-run-gyp-files-for-bundled-deps.patch
+sha512sums="d25f0fe9f12a3d23c09fa3a5794de42755661b82153f5216739690979588290f438f3f3e95566d6ec0b7021e7212afec42c8e08ecb98106f5cc4844a7d46df33 node-v11.6.0.tar.gz
+3697009ae7bf90e7a83da33eac915de9cb32680cafc8003e727540f98942312699e0ee2ebf3014dea15b1f4bcf93f983eec521ad86d75073664c64f5fdeea84d dont-run-gyp-files-for-bundled-deps.patch
adba24239eb8ccb1d27664e9a8b2af0992e2b7b59d03d67bd18598bf0a266f1b572e312980face891f93fad0330488e2af1ab8f524c1798746adb64bed994831 link-with-libatomic-on-mips32.patch"
diff --git a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
index 9d16d17ac3..c140800a34 100644
--- a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
+++ b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
@@ -9,7 +9,7 @@ Node.js 7.2.0
--- a/Makefile
+++ b/Makefile
-@@ -121,14 +121,13 @@ with-code-cache:
+@@ -121,12 +121,12 @@ with-code-cache:
.PHONY: test-code-cache
test-code-cache: with-code-cache
@@ -17,13 +17,10 @@ Node.js 7.2.0
-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
-- deps/v8/gypfiles/features.gypi deps/v8/gypfiles/v8.gyp node.gyp \
-- config.gypi
-+out/Makefile: common.gypi \
-+ deps/v8/gypfiles/toolchain.gypi deps/v8/gypfiles/features.gypi \
-+ deps/v8/gypfiles/v8.gyp node.gyp config.gypi
++out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
++ deps/v8/gypfiles/toolchain.gypi \
+ deps/v8/gypfiles/features.gypi deps/v8/gypfiles/v8.gyp node.gyp \
+ config.gypi
$(PYTHON) tools/gyp_node.py -f make
config.gypi: configure configure.py
- @if [ -x config.status ]; then \
- ./config.status; \