aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-18 17:44:21 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 18:25:23 +0200
commit132a6c800557834a40b7e38d77236c4ac416edd2 (patch)
treeb4d65e7d06bd52f9207d291429dc5cc29321c310 /community/notmuch/APKBUILD
parentc8c613f8c75296d26889dea86679a1fa0944bd75 (diff)
downloadaports-132a6c800557834a40b7e38d77236c4ac416edd2.tar.bz2
aports-132a6c800557834a40b7e38d77236c4ac416edd2.tar.xz
community/notmuch: Reenable testsuite partially
Diffstat (limited to 'community/notmuch/APKBUILD')
-rw-r--r--community/notmuch/APKBUILD46
1 files changed, 35 insertions, 11 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 3ee15c87f3..155cf2879c 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -2,19 +2,21 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
pkgver=0.24.1
-pkgrel=0
+pkgrel=1
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
license="GPL3"
-makedepends="gzip xapian-core-dev gmime-dev talloc-dev
- py-sphinx py-requests bash-completion"
+makedepends="gzip xapian-core-dev gmime-dev talloc-dev py-sphinx
+ py-requests bash-completion"
+checkdepends="sed coreutils diffutils bash tar mdocml grep"
subpackages="
$pkgname-dev
$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz"
+source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
+ fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -27,14 +29,35 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--bashcompletiondir=/usr/share/bash-completion/completions \
- --zshcompletiondir=/usr/share/zsh/site-functions \
- || return 1
- make PREFIX=/usr DESTDIR="$pkgdir" || return 1
+ --zshcompletiondir=/usr/share/zsh/site-functions
+ make PREFIX=/usr DESTDIR="$pkgdir"
}
package() {
make PREFIX=/usr DESTDIR="$pkgdir" \
- -C "$builddir" install || return 1
+ -C "$builddir" install
+}
+
+check() {
+ cd "$builddir"/test
+ make test-binaries
+
+ local test=
+ for test in T*.sh; do
+ name="$(basename "$test")"
+ case "${name%%.*}" in
+ # Requires dtach ↦ doesn't work on the builders
+ *emacs*|T355-smime|T350-crypto) continue ;;
+
+ # XXX: Doesn't pass on the builders for some reason
+ T140-excludes) continue ;;
+
+ # FIXME: These should pass but currently don't
+ T050-new|T150-tagging) continue ;;
+ esac
+
+ ./${test}
+ done
}
bashcomp() {
@@ -44,7 +67,7 @@ bashcomp() {
mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
mv "$pkgdir"/usr/share/bash-completion/completions/$pkgname \
- "$subpkgdir"/usr/share/bash-completion/completions/ || return 1
+ "$subpkgdir"/usr/share/bash-completion/completions/
}
zshcomp() {
@@ -54,7 +77,8 @@ zshcomp() {
mkdir -p "$subpkgdir"/usr/share/zsh/site-functions/
mv "$pkgdir"/usr/share/zsh/site-functions/_${pkgname} \
- "$subpkgdir"/usr/share/zsh/site-functions/ || return 1
+ "$subpkgdir"/usr/share/zsh/site-functions/
}
-sha512sums="e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc notmuch-0.24.1.tar.gz"
+sha512sums="e2014380de68de3e1a3fd3058a441c6771a92bfffe07c0bd2b374802dd8b2539eddbbb91074738f58f48452a936f2f9427fadca825a165c61a27fe0c3e1fe7fc notmuch-0.24.1.tar.gz
+430e8f02b194b0582dfd7c66a2791a0071824e1d215993a6daf89c8d2a1ee7f73a6202136b1d890fc8920a4dc309ae976da8a8b8fc8b90e489d3c04f1592876c fix-tests.patch"