aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch/fix-tests.patch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-17 20:30:25 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-17 20:32:56 +0200
commitabea57f861cf8cf0d0fc065a077ffa1b2ca6a66c (patch)
tree6f5db1e4640114352bc27e984a26066b8a938153 /community/notmuch/fix-tests.patch
parent2c6790a8c5233327fbdd61a5fec71f2aa9727021 (diff)
downloadaports-abea57f861cf8cf0d0fc065a077ffa1b2ca6a66c.tar.bz2
aports-abea57f861cf8cf0d0fc065a077ffa1b2ca6a66c.tar.xz
community/notmuch: enable testsuite partially
Also modernize the APKBUILD
Diffstat (limited to 'community/notmuch/fix-tests.patch')
-rw-r--r--community/notmuch/fix-tests.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/notmuch/fix-tests.patch b/community/notmuch/fix-tests.patch
new file mode 100644
index 0000000000..489959cf4b
--- /dev/null
+++ b/community/notmuch/fix-tests.patch
@@ -0,0 +1,25 @@
+diff -upr notmuch-0.24.1.orig/test/T030-config.sh notmuch-0.24.1/test/T030-config.sh
+--- notmuch-0.24.1.orig/test/T030-config.sh 2017-08-17 19:19:19.245017863 +0200
++++ notmuch-0.24.1/test/T030-config.sh 2017-08-17 19:19:35.725123923 +0200
+@@ -45,8 +45,8 @@ test_expect_equal "$(notmuch config get
+ test_begin_subtest "List all items"
+ notmuch config list 2>&1 | notmuch_config_sanitize > OUTPUT
+ cat <<EOF > EXPECTED
+-Error opening database at MAIL_DIR/.notmuch: No such file or directory
+ database.path=MAIL_DIR
++Error opening database at MAIL_DIR/.notmuch: No such file or directory
+ user.name=Notmuch Test Suite
+ user.primary_email=test_suite@notmuchmail.org
+ user.other_email=test_suite_other@notmuchmail.org;test_suite@otherdomain.org
+diff -upr notmuch-0.24.1.orig/test/T650-regexp-query.sh notmuch-0.24.1/test/T650-regexp-query.sh
+--- notmuch-0.24.1.orig/test/T650-regexp-query.sh 2017-08-17 20:27:35.577369368 +0200
++++ notmuch-0.24.1/test/T650-regexp-query.sh 2017-08-17 20:28:06.570896484 +0200
+@@ -99,7 +99,7 @@ test_begin_subtest "regexp error reporti
+ notmuch search 'from:/unbalanced[/' 1>OUTPUT 2>&1
+ cat <<EOF > EXPECTED
+ notmuch search: A Xapian exception occurred
+-A Xapian exception occurred parsing query: Invalid regular expression
++A Xapian exception occurred parsing query: Missing ']'
+ Query string was: from:/unbalanced[/
+ EOF
+ test_expect_equal_file EXPECTED OUTPUT