aboutsummaryrefslogtreecommitdiffstats
path: root/community/npapi-sdk
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 08:13:17 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commit5af54299c7e8a5ebc5c359a5ae74de08fea516e2 (patch)
treebce9b102c94b30ff59657f5ddd06a62abe7d7ef5 /community/npapi-sdk
parentf16d76810d87280a235f5f4d8b120b9cdadae27d (diff)
downloadaports-5af54299c7e8a5ebc5c359a5ae74de08fea516e2.tar.bz2
aports-5af54299c7e8a5ebc5c359a5ae74de08fea516e2.tar.xz
community/npapi-sdk: moved from main
Diffstat (limited to 'community/npapi-sdk')
-rw-r--r--community/npapi-sdk/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/npapi-sdk/APKBUILD b/community/npapi-sdk/APKBUILD
new file mode 100644
index 0000000000..c2b9a07067
--- /dev/null
+++ b/community/npapi-sdk/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=npapi-sdk
+pkgver=0.27.2
+pkgrel=0
+pkgdesc="Netscape Plugin API (NPAPI)"
+url="https://bitbucket.org/mgorny/npapi-sdk"
+arch="all"
+license="MPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="https://bitbucket.org/mgorny/npapi-sdk/downloads/npapi-sdk-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/npapi-sdk-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e81db61e206cd615cf56c4a9f301e636 npapi-sdk-0.27.2.tar.bz2"
+sha256sums="01bf34bdd0fcaa546ba3d5c96f5d91f91dd117d4ed5ffe13f56bbd5aa566ae77 npapi-sdk-0.27.2.tar.bz2"
+sha512sums="827d52fbc8eb601ac0e486aed267b1ca6cb8732c92f1224f4b38e039288b77d07d47c5d4cf384a3114403b85e7f086f345912f1b20b41d27785c9bb367514842 npapi-sdk-0.27.2.tar.bz2"