aboutsummaryrefslogtreecommitdiffstats
path: root/community/nuttcp
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-12-04 19:40:44 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-12-07 15:55:25 +0100
commit46f2e7a58df7539ad0da65098948c31a7d558c7e (patch)
tree5d38a6d67d848866e5a53cde889caafd9eeb62e0 /community/nuttcp
parent72ac6491429944b7864cf6ea26dead4846c16003 (diff)
downloadaports-46f2e7a58df7539ad0da65098948c31a7d558c7e.tar.bz2
aports-46f2e7a58df7539ad0da65098948c31a7d558c7e.tar.xz
unmaintained/nuttcp: move to community
Diffstat (limited to 'community/nuttcp')
-rw-r--r--community/nuttcp/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/nuttcp/APKBUILD b/community/nuttcp/APKBUILD
new file mode 100644
index 0000000000..0b6d2345a8
--- /dev/null
+++ b/community/nuttcp/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Danilo Godec <danilo.godec@agenda.si>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=nuttcp
+pkgver=8.1.4
+pkgrel=0
+pkgdesc="A network performance measurement tool"
+url="http://www.nuttcp.net"
+arch="all"
+license="GPL2"
+makedepends="linux-headers"
+source="http://nuttcp.net/nuttcp/nuttcp-$pkgver/nuttcp-$pkgver.c"
+builddir="$srcdir"/
+
+build() {
+ cd "$builddir"
+ ${CC:-gcc} $CFLAGS -o nuttcp $LDFLAGS "$srcdir"/nuttcp-$pkgver.c
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 nuttcp "$pkgdir"/usr/sbin/nuttcp
+}
+
+md5sums="f3e236273f509f4f3993d9f842ffd860 nuttcp-8.1.4.c"
+sha256sums="d063efc143ed4e740439b859be075b4a4c35194a7d47e62378dd44d73974cfd7 nuttcp-8.1.4.c"
+sha512sums="5bc1505d708ed9555c03bb5358f8a94f483b725d99c5b1de74447a888bb4d9485385602538d7be2b56026a87f9fd2255744e7528f92cfb5fe54f5f4ab7c2e1fc nuttcp-8.1.4.c"