aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml-lablgtk/ignore-warnings.patch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-12-05 13:32:04 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-12-05 13:34:18 +0100
commit6604e61e8a21c725e8ccd9bbb4670fa99c4b8bac (patch)
treeb61fb4c636493b53586eae7c134f0bf63ec58a24 /community/ocaml-lablgtk/ignore-warnings.patch
parent90c90abb73119d17db970f3694bfe81a19e66cf9 (diff)
downloadaports-6604e61e8a21c725e8ccd9bbb4670fa99c4b8bac.tar.bz2
aports-6604e61e8a21c725e8ccd9bbb4670fa99c4b8bac.tar.xz
community/ocaml-lablgtk: do not treat warnings as errors
Should fix the build on all previously enabled platforms.
Diffstat (limited to 'community/ocaml-lablgtk/ignore-warnings.patch')
-rw-r--r--community/ocaml-lablgtk/ignore-warnings.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/community/ocaml-lablgtk/ignore-warnings.patch b/community/ocaml-lablgtk/ignore-warnings.patch
new file mode 100644
index 0000000000..b829097ce3
--- /dev/null
+++ b/community/ocaml-lablgtk/ignore-warnings.patch
@@ -0,0 +1,23 @@
+Without this patch Lablgtk treats warnings as errors.
+
+This causes the build to fail with our currently packed ocaml version:
+
+ File "gdk.ml", line 346, characters 2-55:
+ 346 | external create : len:int -> t = "ml_point_array_new"
+ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+ Error (warning 61): This primitive declaration uses type t, which is unannotated and
+ unboxable. The representation of such types may change in future
+ versions. You should annotate the declaration of t with [@@boxed]
+ or [@@unboxed].
+
+diff -upr lablgtk-2.18.6.orig/src/Makefile lablgtk-2.18.6/src/Makefile
+--- lablgtk-2.18.6.orig/src/Makefile 2019-12-05 13:29:04.763064450 +0100
++++ lablgtk-2.18.6/src/Makefile 2019-12-05 13:29:20.569735224 +0100
+@@ -1,6 +1,6 @@
+ # Makefile for lablgtk.
+
+-COMPILER = $(CAMLC) $(MLFLAGS) $(MLBYTEFLAGS) -w s-3+52 -warn-error A-52 -c
++COMPILER = $(CAMLC) $(MLFLAGS) $(MLBYTEFLAGS) -w s-3+52 -c
+ LINKER = $(CAMLC) $(MLFLAGS) $(MLBYTEFLAGS)
+ COMPOPT = $(CAMLOPT) $(MLFLAGS) -w s -c
+ LINKOPT = $(CAMLOPT) $(MLFLAGS)