aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml/APKBUILD
diff options
context:
space:
mode:
authorPedro Filipe <pedrofilipecerqueira@outlook.com>2019-07-16 15:19:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-17 06:01:13 -0300
commitf37c80a85d4121a74600479cc7064a855b83bcd6 (patch)
treeb2cec937cacdb70ded5b54c99442c1673d2b9f85 /community/ocaml/APKBUILD
parent2ea2cc5ac1ede223f8f226758eec4cd6efe57f42 (diff)
downloadaports-f37c80a85d4121a74600479cc7064a855b83bcd6.tar.bz2
aports-f37c80a85d4121a74600479cc7064a855b83bcd6.tar.xz
community/ocaml: update to 4.08.0
Fixes https://gitlab.alpinelinux.org/alpine/aports/issues/10583
Diffstat (limited to 'community/ocaml/APKBUILD')
-rw-r--r--community/ocaml/APKBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 12b997b34a..b8be0a1e06 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml
-pkgver=4.07.1
-pkgrel=1
+pkgver=4.08.0
+pkgrel=0
pkgdesc="Main implementation of the Caml programming language"
url="http://ocaml.org/"
arch="aarch64 ppc64le x86_64"
@@ -20,23 +20,22 @@ subpackages="
"
source="http://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/$pkgname-$pkgver.tar.gz
compile-without-debug-info.patch
- fix-mcontext-fields.patch
+ fix-mcontext-fields.patch
fix-segfault-in-ppc64le.patch
+ fix-check-parser-uptodate-or-warn.sh.patch
"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
-
./configure \
--prefix /usr \
--bindir /usr/bin \
--libdir /usr/lib/ocaml \
--mandir /usr/share/man \
- -cc "${CC:-gcc}" \
- -as "${CC:-gcc} -c" \
- -aspp "${CC:-gcc} -c" \
- -fPIC
+ CC="${CC:-gcc}" \
+ AS="${CC:-gcc} -c" \
+ ASPP="${CC:-gcc} -c"
make world.opt
}
@@ -119,7 +118,8 @@ _submv() {
rmdir -p "$pkgdir"/${path%/*} 2>/dev/null || true
}
-sha512sums="a7faed1759f76b91afb0922de159240cc11d68f89e2136d2f3add4d3e66fe923f27a094a937a7d7e73727a1675864e8ff41882eeaa4212d8c4dfeb2811e1707a ocaml-4.07.1.tar.gz
-b42af74ae80428a0488bbb182ca5f48d35ce34d6ba336aa10904a78863e7e1e6b61303d5cd3ad89cba5329cb0983692ba92341e2058ea3e31bb22aa4f7b46dd8 compile-without-debug-info.patch
-75c67e143a4a05b334bdebbad48ded1e04d383d8ea9b747df2633a5af96b1115b502510faf57753c71bbac38fbc9d9746b167861a63b2fd295901db0d22ea317 fix-mcontext-fields.patch
-b2cef41400b31c1dcfd206c1534827f7b33b0afd6234b26fb95cf15c092affa85c27a615c14ece254ec326430f31b58ca70b9cc23a84ebf8baac2624bd5b0a71 fix-segfault-in-ppc64le.patch"
+sha512sums="7d2f02e7eda7a1ce619876afbc484c83b22ed23ab06309a6a04cc99fd552e9358450261a9dee96e4d29d23fa900d5948e62f15b11ce00e23fea6a2bf6d3babab ocaml-4.08.0.tar.gz
+49cbd6df3a70d00df33d34ab4508dd04d52cbc94efc6c8cac8668758e7346be3c7acedf5b8af38a0adb18c69b8d0859667b12cc11699002c048af962cf283ad2 compile-without-debug-info.patch
+cd0b9a8c3dc8d952a40eb1758cc74dc388ec4bcc5fe5a25c3f073f0088bf51027b53ea1b9f6d02a84b11bd3964bec1c50b5da28caa7c1e31ec76f9930ea7d527 fix-mcontext-fields.patch
+e65b647427d9c94933d5be97857daf8cdc65e25c10066740dbcbab7a4e6f8ddb2277ee7d5796abf5916e5bdd59b057de736190432c480fc8ff2a4b2a94d46eca fix-segfault-in-ppc64le.patch
+b3362906c23ecdb084db7dbf18cae22f0a54ba968f1ecf9c8d13c230ca221b3f77fa820a52e091ce7b71b1cb4a91faf1346692aa6fa411bb46fca784500def25 fix-check-parser-uptodate-or-warn.sh.patch"