aboutsummaryrefslogtreecommitdiffstats
path: root/community/omxplayer
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-12-31 07:45:20 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-12-31 09:48:13 +0200
commit798cef5e2bca37bc0fa462084df3ae6473d65255 (patch)
treebe0fc6ac2c7ff9804d6ebbec76586f96448a214c /community/omxplayer
parent66410c03ee76348b5411eb70cc5fda5c56a2d625 (diff)
downloadaports-798cef5e2bca37bc0fa462084df3ae6473d65255.tar.bz2
aports-798cef5e2bca37bc0fa462084df3ae6473d65255.tar.xz
community/omxplayer: upgrade to snapshot 2018-12-27, fix armv7
Take out all CPU specific compiler flags and rely on gcc defaults. The problem on armv7 was that configuring manually armv6 and using gcc default for thumb tries to build using thumb1 which does not work. Use Alpine default config for these which is proper combination.
Diffstat (limited to 'community/omxplayer')
-rw-r--r--community/omxplayer/APKBUILD10
-rw-r--r--community/omxplayer/fix-makefile.patch14
2 files changed, 14 insertions, 10 deletions
diff --git a/community/omxplayer/APKBUILD b/community/omxplayer/APKBUILD
index bb9a994aee..9c11f513b3 100644
--- a/community/omxplayer/APKBUILD
+++ b/community/omxplayer/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=omxplayer
-pkgver=0.20180516
-_commitid=96800576209bbf02939a3d71dec91ec1c1da586b
+pkgver=0.20181227
+_commitid=a447d4fd42252ff7c341ac8eb3123c77a8dbf52b
pkgrel=0
pkgdesc="Commandline OMX player for Raspberry Pi"
url="https://github.com/popcornmix/omxplayer"
arch="armhf armv7"
license="GPL-2.0"
depends="ttf-freefont"
-makedepends="linux-headers raspberrypi-dev ffmpeg-dev pcre-dev
+makedepends="linux-headers raspberrypi-dev>=0.20181212 ffmpeg-dev pcre-dev
boost-dev freetype-dev dbus-dev alsa-lib-dev"
install=""
options="!check"
@@ -50,10 +50,10 @@ package() {
"$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="4e523fad139a5afe6c5fa74e0966fd5229259bfe9963c28b9ba7841ec5b895094d10c33340703fc0e2559fd2e9f3c9331cd8f161c1645f188ca592542648b25c omxplayer-0.20180516.tar.gz
+sha512sums="bab281b56964623bdb8a95797f5976a5608b89bde5c8640bc653d765acd67420649de09c89d7fb43672bd55e8031c3d7eeb4991cfdcc35503959ac954e517a7b omxplayer-0.20181227.tar.gz
c349eea5f7c513a07d82a6cf6467c4d21bcb29c053bc5e39d8f675b1212db9beef0abf5248d50ac5a2f14fda73055786f94f421377ffcf5f6bcf8daa2f1b56e8 issue-260.patch
2a8a6def1e09f726cba58c0b9109fa6c4fbd4a3b4f1d27d200488f262a0e0978579d83db7fe24f1d3e03beef318c3674ed79cbd2f1994c4551a59c9fe0f63489 issue-297.patch
-009ae8398755417d1a13ed15bcfdc6ce43fb637db153c51c15b00ef0edf82117dfb2964d5e37e0baf30e4ef1e3003546ae39e42a492e75fcdfc15d751e1ad516 fix-makefile.patch
+3493d9600fda75a7599fada332c48e8790dcc46ada65b862bb14dafb701dd7ed89f3debf439160917b73d779f549898146b394e13c45dc7d77122a11a2ede97e fix-makefile.patch
8aa58aaa07453186302dc68d92f28c1b50bf0f8fccd50359640a7fc8339b233b32a0c8c02284a9974599e56d69cc557acc25e76e6438c6d64d15afd9c1788a8e default-font.patch
3ddd32235d87a46478d0237ee9b253edeb75729e377b09a33069ecdca2ee230d2851f308897ee75ff69a9f3bdd2876f490bc1667a572dce1c186f80fddcf6df3 omxplayer.initd
4f906ada035869a0e515e7615056b18b0f6906ce4b3a2d34081c0efa79bb9455380f729e7c5270180f5ace89c53a7ac7c93f609e6761825f639f44aa22346bb2 omxplayer.confd"
diff --git a/community/omxplayer/fix-makefile.patch b/community/omxplayer/fix-makefile.patch
index 88dd8d376f..445c9361a6 100644
--- a/community/omxplayer/fix-makefile.patch
+++ b/community/omxplayer/fix-makefile.patch
@@ -1,6 +1,9 @@
---- omxplayer-2ee17b22a6149a043a2e402580504f282c615373.orig/Makefile 2017-10-17 19:51:35.000000000 +0300
-+++ omxplayer-2ee17b22a6149a043a2e402580504f282c615373/Makefile 2017-11-21 15:43:30.122410419 +0200
-@@ -3,8 +3,11 @@
+--- omxplayer-a447d4fd42252ff7c341ac8eb3123c77a8dbf52b.orig/Makefile
++++ omxplayer-a447d4fd42252ff7c341ac8eb3123c77a8dbf52b/Makefile
+@@ -1,11 +1,14 @@
+-CFLAGS=-pipe -mfloat-abi=hard -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
++CFLAGS=-pipe -fomit-frame-pointer -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
+ CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
@@ -8,11 +11,12 @@
+LIBS+=-lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
-+
-+INCLUDES+=-I./ -Ilinux $(shell pkg-config --cflags dbus-1 freetype2) -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
++INCLUDES+=-I./ -Ilinux $(shell pkg-config --cflags dbus-1 freetype2) -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
++
DIST ?= omxplayer-dist
STRIP ?= strip
+
@@ -50,10 +53,10 @@
omxplayer.o: help.h keys.h