aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam
diff options
context:
space:
mode:
authorAnil Madhavapeddy <anil@recoil.org>2018-10-23 19:48:47 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-25 10:03:18 +0000
commit2bedfb52bb094dc243ab9da2a67a4f91c8fde4cc (patch)
tree256c1bb47fe8b2ea992c86053d578c4d3d2817a2 /community/opam
parentd27a25e7df520d456981f4e75ea60e8989894ece (diff)
downloadaports-2bedfb52bb094dc243ab9da2a67a4f91c8fde4cc.tar.bz2
aports-2bedfb52bb094dc243ab9da2a67a4f91c8fde4cc.tar.xz
community/opam: upgrade to 2.0.1
Diffstat (limited to 'community/opam')
-rw-r--r--community/opam/APKBUILD28
-rw-r--r--community/opam/fix-default-stubsdir.patch24
2 files changed, 15 insertions, 37 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 7306f66851..ba96c31029 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -1,18 +1,17 @@
# Contributor: Michael Zuo <muh.muhten@gmail.com>
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
-# FIXME: lib-ext downloads dependencies; package them and use system-provided!
pkgname=opam
-pkgver=1.2.2
-pkgrel=4
+pkgver=2.0.1
+pkgrel=0
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !armv7 !s390x" # ocaml not avail on excluded platforms
-license="LGPL-3.0"
-depends="ocaml ocaml-camlp4 curl tar unzip rsync aspcud patch"
-makedepends="ocaml-compiler-libs ocaml-camlp4-dev"
-source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
- fix-default-stubsdir.patch"
+license="LGPL-2.1"
+depends="ocaml curl xz tar unzip rsync patch bubblewrap bash"
+makedepends="ocaml-compiler-libs"
+source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-full-$pkgver"
+subpackages="$pkgname-doc"
build() {
cd "$builddir"
@@ -26,9 +25,8 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var
- # -unsafe-string needed to make it build with ocaml >=4.06.
- OCAMLFLAGS="-unsafe-string" \
- make -j1 lib-ext all
+ make -j1 lib-ext
+ make -j1 all
}
package() {
@@ -36,5 +34,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f095ef4c02e6a411ee115b508c7dc21cf6480f60ad5d84ed5ce5868afa1f6225ead0eb6703763d803edc22595e83db67cdd1a4ecab50ee2c62c20965b0542436 opam-full-1.2.2.tar.gz
-704a9d36b93267a982fd5bad99637338afab6b0a8edbbb127e17065e27d54ef752a10565e8078e1c4d63e16f95f5df11fd1f26de4925042a57b0dd678fe33d2e fix-default-stubsdir.patch"
+check() {
+ cd "$builddir"
+ make tests
+}
+
+sha512sums="add6cd77067cddadd4be5d79699713211f5f2796c1e1931048eb5fc4f0127eca56e1f81d43335327ae04e2144186d9ce759e844d2a125ef27f22c26cd8153e3c opam-full-2.0.1.tar.gz"
diff --git a/community/opam/fix-default-stubsdir.patch b/community/opam/fix-default-stubsdir.patch
deleted file mode 100644
index 1cc48dec4e..0000000000
--- a/community/opam/fix-default-stubsdir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 718d6198e338069852dcdde067f56df236235370 Mon Sep 17 00:00:00 2001
-From: Louis Gesbert <louis.gesbert@ocamlpro.com>
-Date: Mon, 7 Aug 2017 12:45:47 +0200
-Subject: [PATCH] Fix opam-installer (stubsdir = "stubslibs" -> "stublibs")
-
-Patch-Source: https://github.com/ocaml/opam/commit/718d6198e338069852dcdde067f56df236235370
-See-Also: https://github.com/ocaml/dune/issues/108#issuecomment-329178318
----
- src/tools/opam_installer.ml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/tools/opam_installer.ml b/src/tools/opam_installer.ml
-index b35af249b..3e5ebfcb9 100644
---- a/src/tools/opam_installer.ml
-+++ b/src/tools/opam_installer.ml
-@@ -312,7 +312,7 @@
- let mandir = mk_dir mandir in
- let libdir = mk_dir libdir in
- let stubsdir = match mk_dir stubsdir, libdir with
-- | None, Some d -> Some OpamFilename.OP.(d / "stubslibs")
-+ | None, Some d -> Some OpamFilename.OP.(d / "stublibs")
- | d, None | (Some _ as d), _ -> d
- in
- let topdir = match mk_dir topdir, libdir with