aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-08 16:41:00 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-08 16:45:30 +0100
commit30030d2968ec0c7c556986124575b054867caff5 (patch)
tree3afaeaf014ba055a3ac47b9e41b418c677e27097 /community/opam
parentd118b3f909b51491f697a99be15df39a8aa3676b (diff)
downloadaports-30030d2968ec0c7c556986124575b054867caff5.tar.bz2
aports-30030d2968ec0c7c556986124575b054867caff5.tar.xz
community/opam: modernize abuild
Diffstat (limited to 'community/opam')
-rw-r--r--community/opam/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index ada9189afe..2816d601b0 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -9,14 +9,13 @@ arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-3.0"
depends="ocaml camlp4 curl tar unzip rsync aspcud patch"
makedepends="$depends_dev"
-install=""
-subpackages=""
source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
fix-default-stubsdir.patch"
-builddir="$srcdir"/$pkgname-full-$pkgver
+builddir="$srcdir/$pkgname-full-$pkgver"
build() {
cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -24,14 +23,13 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make -j1 lib-ext all || return 1
+ --localstatedir=/var
+ make -j1 lib-ext all
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="f095ef4c02e6a411ee115b508c7dc21cf6480f60ad5d84ed5ce5868afa1f6225ead0eb6703763d803edc22595e83db67cdd1a4ecab50ee2c62c20965b0542436 opam-full-1.2.2.tar.gz