aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 13:58:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 14:14:55 +0100
commitc08b511b05262a5f38b413e476986e5b919cf279 (patch)
treed147cbd26303507e8dcc8b0a92e6c5d8eed70bc8 /community/opam
parentad2c95988babb7e4e20dc99c99586a3fd0ab7c7d (diff)
downloadaports-c08b511b05262a5f38b413e476986e5b919cf279.tar.bz2
aports-c08b511b05262a5f38b413e476986e5b919cf279.tar.xz
community/opam: drop dependency on standalone xz
Diffstat (limited to 'community/opam')
-rw-r--r--community/opam/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 9fc68ba862..fd04e8252a 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -2,20 +2,18 @@
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=opam
pkgver=2.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !armv7" # ocaml not avail on excluded platforms
license="LGPL-2.1"
-depends="ocaml curl xz tar unzip rsync patch bubblewrap bash"
+depends="ocaml curl tar unzip rsync patch bubblewrap bash"
makedepends="ocaml-compiler-libs"
-source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz"
+source="https://github.com/ocaml/opam/releases/download/$pkgver/opam-full-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-full-$pkgver"
subpackages="$pkgname-doc"
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,12 +28,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
make tests
}