aboutsummaryrefslogtreecommitdiffstats
path: root/community/opam
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-08 16:39:07 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-08 16:45:30 +0100
commitd118b3f909b51491f697a99be15df39a8aa3676b (patch)
treebcfc27e6d571e9bc04921a876f7e3418d146e53a /community/opam
parentf409292f85cda970596e57df65fea69dd35fe168 (diff)
downloadaports-d118b3f909b51491f697a99be15df39a8aa3676b.tar.bz2
aports-d118b3f909b51491f697a99be15df39a8aa3676b.tar.xz
community/opam: fix stubsdir name from stubslibs to stublibs
Diffstat (limited to 'community/opam')
-rw-r--r--community/opam/APKBUILD10
-rw-r--r--community/opam/fix-default-stubsdir.patch24
2 files changed, 29 insertions, 5 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 75b5403a92..ada9189afe 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=opam
pkgver=1.2.2
-pkgrel=2
+pkgrel=3
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
@@ -11,7 +11,8 @@ depends="ocaml camlp4 curl tar unzip rsync aspcud patch"
makedepends="$depends_dev"
install=""
subpackages=""
-source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz"
+source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
+ fix-default-stubsdir.patch"
builddir="$srcdir"/$pkgname-full-$pkgver
build() {
@@ -33,6 +34,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="7d348c2898795e9f325fb80eaaf5eae8 opam-full-1.2.2.tar.gz"
-sha256sums="15e617179251041f4bf3910257bbb8398db987d863dd3cfc288bdd958de58f00 opam-full-1.2.2.tar.gz"
-sha512sums="f095ef4c02e6a411ee115b508c7dc21cf6480f60ad5d84ed5ce5868afa1f6225ead0eb6703763d803edc22595e83db67cdd1a4ecab50ee2c62c20965b0542436 opam-full-1.2.2.tar.gz"
+sha512sums="f095ef4c02e6a411ee115b508c7dc21cf6480f60ad5d84ed5ce5868afa1f6225ead0eb6703763d803edc22595e83db67cdd1a4ecab50ee2c62c20965b0542436 opam-full-1.2.2.tar.gz
+704a9d36b93267a982fd5bad99637338afab6b0a8edbbb127e17065e27d54ef752a10565e8078e1c4d63e16f95f5df11fd1f26de4925042a57b0dd678fe33d2e fix-default-stubsdir.patch"
diff --git a/community/opam/fix-default-stubsdir.patch b/community/opam/fix-default-stubsdir.patch
new file mode 100644
index 0000000000..1cc48dec4e
--- /dev/null
+++ b/community/opam/fix-default-stubsdir.patch
@@ -0,0 +1,24 @@
+From 718d6198e338069852dcdde067f56df236235370 Mon Sep 17 00:00:00 2001
+From: Louis Gesbert <louis.gesbert@ocamlpro.com>
+Date: Mon, 7 Aug 2017 12:45:47 +0200
+Subject: [PATCH] Fix opam-installer (stubsdir = "stubslibs" -> "stublibs")
+
+Patch-Source: https://github.com/ocaml/opam/commit/718d6198e338069852dcdde067f56df236235370
+See-Also: https://github.com/ocaml/dune/issues/108#issuecomment-329178318
+---
+ src/tools/opam_installer.ml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tools/opam_installer.ml b/src/tools/opam_installer.ml
+index b35af249b..3e5ebfcb9 100644
+--- a/src/tools/opam_installer.ml
++++ b/src/tools/opam_installer.ml
+@@ -312,7 +312,7 @@
+ let mandir = mk_dir mandir in
+ let libdir = mk_dir libdir in
+ let stubsdir = match mk_dir stubsdir, libdir with
+- | None, Some d -> Some OpamFilename.OP.(d / "stubslibs")
++ | None, Some d -> Some OpamFilename.OP.(d / "stublibs")
+ | d, None | (Some _ as d), _ -> d
+ in
+ let topdir = match mk_dir topdir, libdir with