aboutsummaryrefslogtreecommitdiffstats
path: root/community/openal-soft/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 01:24:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 01:24:02 -0300
commit97a6ffe36405b0a02129c11bea5bf9d5080a5a53 (patch)
tree336765f0e844cb2c1ed7240cca8a75a0a863a7e2 /community/openal-soft/APKBUILD
parent4639fbbcc2a8972492b1c1b5f35b9178e0904a0d (diff)
downloadaports-97a6ffe36405b0a02129c11bea5bf9d5080a5a53.tar.bz2
aports-97a6ffe36405b0a02129c11bea5bf9d5080a5a53.tar.xz
community/openal-soft: fix build
Diffstat (limited to 'community/openal-soft/APKBUILD')
-rw-r--r--community/openal-soft/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/community/openal-soft/APKBUILD b/community/openal-soft/APKBUILD
index 8c61c0d7de..fa21715aab 100644
--- a/community/openal-soft/APKBUILD
+++ b/community/openal-soft/APKBUILD
@@ -13,9 +13,8 @@ subpackages="$pkgname-dev"
source="http://kcat.strangesoft.net/openal-releases/${pkgname}-${pkgver}.tar.bz2"
options="!check"
-builddir="${srcdir}/${pkgname}-${pkgver}"
+builddir="${srcdir}/${pkgname}-${pkgver}/build"
-builddir="${srcdir}/build"
prepare() {
default_prepare
mkdir -p "$builddir"
@@ -29,7 +28,7 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
$_cpuext_neon \
- "$builddir"
+ ..
make
}