aboutsummaryrefslogtreecommitdiffstats
path: root/community/openblas
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-09-08 20:48:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-09-08 20:49:20 +0200
commit380808d0172224bbfca1e6f49a37fd847575d342 (patch)
tree529bea84137aab7fc8797e7cf93883e88a03230d /community/openblas
parent8a1b950292f94ebc074b735cec89dc0a47648468 (diff)
downloadaports-380808d0172224bbfca1e6f49a37fd847575d342.tar.bz2
aports-380808d0172224bbfca1e6f49a37fd847575d342.tar.xz
community/openblas: add check
Diffstat (limited to 'community/openblas')
-rw-r--r--community/openblas/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/openblas/APKBUILD b/community/openblas/APKBUILD
index cd3fc4e94b..43fa0177d2 100644
--- a/community/openblas/APKBUILD
+++ b/community/openblas/APKBUILD
@@ -4,7 +4,7 @@
pkgname=openblas
_pkgname=OpenBLAS
pkgver=0.3.3
-pkgrel=0
+pkgrel=1
pkgdesc="A fast BSD-licensed BLAS based on gotoBLAS2, with LAPACK"
url="http://www.openblas.net"
arch="all"
@@ -74,6 +74,11 @@ build() {
fi
}
+check() {
+ cd "$builddir"
+ CFLAGS= make $_flags CFLAGS="$CFLAGS" tests
+}
+
package() {
if $_ilp64; then
make -C "$_builddir64" $_flags64 \