aboutsummaryrefslogtreecommitdiffstats
path: root/community/opencpn/CMakeList.txt.patch
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-08-18 12:58:33 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-18 21:11:39 +0000
commitfad19051951129081c94d9ca641af6bbb1389e20 (patch)
tree4f6fac56923653086b9db2df0052a834b70b6966 /community/opencpn/CMakeList.txt.patch
parent5df6fbc76284929c44d2db7db6d12f675a91958c (diff)
downloadaports-fad19051951129081c94d9ca641af6bbb1389e20.tar.bz2
aports-fad19051951129081c94d9ca641af6bbb1389e20.tar.xz
testing/[various]: move to community
Moves the following packages to community after successful build and testing. bogofilter corebird fbpanel hermes libdbi-drivers luufs netsurf opencpn py-sensehat rng-tools volumeicon
Diffstat (limited to 'community/opencpn/CMakeList.txt.patch')
-rw-r--r--community/opencpn/CMakeList.txt.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/opencpn/CMakeList.txt.patch b/community/opencpn/CMakeList.txt.patch
new file mode 100644
index 0000000000..8a1341d424
--- /dev/null
+++ b/community/opencpn/CMakeList.txt.patch
@@ -0,0 +1,13 @@
+index 967e558..27bad69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -489,6 +489,9 @@ IF(OCPN_USE_CRASHREPORT)
+ IF(CMAKE_BUILD_TYPE MATCHES "Rel*")
+ MESSAGE (STATUS "Using Linux crash reporting")
+ ADD_DEFINITIONS(-DLINUX_CRASHRPT)
++ IF(EXISTS /etc/alpine-release)
++ SET(EXTRA_LIBS ${EXTRA_LIBS} "execinfo")
++ ENDIF(EXISTS alpine-release)
+ ENDIF(CMAKE_BUILD_TYPE MATCHES "Rel*")
+ ENDIF(NOT APPLE AND NOT QT_ANDROID AND NOT MINGW)
+ ENDIF(MSVC