aboutsummaryrefslogtreecommitdiffstats
path: root/community/opencpn/CMakeList.txt.patch
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-19 19:59:14 +0200
committerTBK <tbk@jjtc.eu>2019-05-19 19:59:55 +0200
commitd9e67a9156a75a51587b1e85a959cc8e9d01dfb4 (patch)
tree1e57c618ceec77e7a31233a7c271106b0c100562 /community/opencpn/CMakeList.txt.patch
parent77c58c39d1c624667ceaddce4e4c57ce754cca97 (diff)
downloadaports-d9e67a9156a75a51587b1e85a959cc8e9d01dfb4.tar.bz2
aports-d9e67a9156a75a51587b1e85a959cc8e9d01dfb4.tar.xz
community/opencpn: fix issue with cmake 3.14.0+
Diffstat (limited to 'community/opencpn/CMakeList.txt.patch')
-rw-r--r--community/opencpn/CMakeList.txt.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/opencpn/CMakeList.txt.patch b/community/opencpn/CMakeList.txt.patch
index 8a1341d424..ca55859d25 100644
--- a/community/opencpn/CMakeList.txt.patch
+++ b/community/opencpn/CMakeList.txt.patch
@@ -1,13 +1,14 @@
-index 967e558..27bad69 100644
+https://github.com/OpenCPN/OpenCPN/issues/676
+
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -489,6 +489,9 @@ IF(OCPN_USE_CRASHREPORT)
+@@ -534,6 +534,9 @@
IF(CMAKE_BUILD_TYPE MATCHES "Rel*")
- MESSAGE (STATUS "Using Linux crash reporting")
+ MESSAGE (STATUS "Using Linux crash reporting")
ADD_DEFINITIONS(-DLINUX_CRASHRPT)
+ IF(EXISTS /etc/alpine-release)
+ SET(EXTRA_LIBS ${EXTRA_LIBS} "execinfo")
+ ENDIF(EXISTS alpine-release)
ENDIF(CMAKE_BUILD_TYPE MATCHES "Rel*")
ENDIF(NOT APPLE AND NOT QT_ANDROID AND NOT MINGW)
- ENDIF(MSVC
+ ENDIF(MSVC)