aboutsummaryrefslogtreecommitdiffstats
path: root/community/opencpn
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-19 19:59:14 +0200
committerTBK <tbk@jjtc.eu>2019-05-19 19:59:55 +0200
commitd9e67a9156a75a51587b1e85a959cc8e9d01dfb4 (patch)
tree1e57c618ceec77e7a31233a7c271106b0c100562 /community/opencpn
parent77c58c39d1c624667ceaddce4e4c57ce754cca97 (diff)
downloadaports-d9e67a9156a75a51587b1e85a959cc8e9d01dfb4.tar.bz2
aports-d9e67a9156a75a51587b1e85a959cc8e9d01dfb4.tar.xz
community/opencpn: fix issue with cmake 3.14.0+
Diffstat (limited to 'community/opencpn')
-rw-r--r--community/opencpn/APKBUILD7
-rw-r--r--community/opencpn/CMakeList-wxWidgets.patch52
-rw-r--r--community/opencpn/CMakeList.txt.patch9
3 files changed, 62 insertions, 6 deletions
diff --git a/community/opencpn/APKBUILD b/community/opencpn/APKBUILD
index f8aa84aa2d..cb56fa61fd 100644
--- a/community/opencpn/APKBUILD
+++ b/community/opencpn/APKBUILD
@@ -13,7 +13,9 @@ makedepends="wxgtk-dev libexecinfo-dev linux-headers curl-dev cmake gpsd portaud
install=""
subpackages="$pkgname-doc $pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/OpenCPN/OpenCPN/archive/v${pkgver}.tar.gz
-CMakeList.txt.patch"
+ CMakeList.txt.patch
+ CMakeList-wxWidgets.patch
+ "
builddir="$srcdir/OpenCPN-${pkgver}"
@@ -33,4 +35,5 @@ package() {
}
sha512sums="d5b06446772cd23677bef56a994b98f1ab6709687cf414954d951718f68b04a27f1fd2010a7c6e2fbc57c29639282fe9bc25a6e2c1b46a23d67a7817ce61fc9f opencpn-4.8.4.tar.gz
-79daf622a5a9a54db81a09bc1004819bb4d20ce2959a4d3204e8ff09d4669e55ebb85b37961397cc6c8a00b87e081126685c51f6bdb78d9d324ce4f7c8b2f2ef CMakeList.txt.patch"
+a0cb0742f5d93e9e32529775d2d90ccaad6bec7e217e2fa08c6a3130c0cfbdb91ed4bf3a14db2a453f95a59d383fb7d698c33795f326597edf7d2e198d094b64 CMakeList.txt.patch
+34d17ee1e01eceb79702c642bdfb392178633525aca059c07bc424691aaafb5252d56c4c3b9d42d7273f6663f33b1a18ee653964274b790cf6bd2ab6e57a8635 CMakeList-wxWidgets.patch"
diff --git a/community/opencpn/CMakeList-wxWidgets.patch b/community/opencpn/CMakeList-wxWidgets.patch
new file mode 100644
index 0000000000..1a708b3248
--- /dev/null
+++ b/community/opencpn/CMakeList-wxWidgets.patch
@@ -0,0 +1,52 @@
+Issue with cmake 3.14.0+ - https://github.com/OpenCPN/OpenCPN/issues/1329#issuecomment-477118399
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -335,9 +335,9 @@
+ ENDIF()
+
+ IF((_wx_selected_config MATCHES "qt-armv7"))
+-SET(wxWidgets_USE_LIBS base core xml html adv aui)
++SET(wxWidgets_FIND_COMPONENTS base core xml html adv aui)
+ ELSE()
+- SET(wxWidgets_USE_LIBS net xml html adv aui core base)
++ SET(wxWidgets_FIND_COMPONENTS net xml html adv aui core base)
+ ENDIF()
+
+ OPTION (USE_GL "Enable OpenGL support" ON)
+@@ -354,7 +354,7 @@
+ SET(OPENGLES_FOUND "YES")
+ SET(OPENGL_FOUND "YES")
+
+- SET(wxWidgets_USE_LIBS ${wxWidgets_USE_LIBS} gl )
++ SET(wxWidgets_FIND_COMPONENTS ${wxWidgets_FIND_COMPONENTS} gl )
+ add_subdirectory(src/glshim)
+
+ SET(OPENGL_LIBRARIES "GL_static" "EGL" "X11" "drm" )
+@@ -373,7 +373,7 @@
+ SET(OPENGLES_FOUND "YES")
+ SET(OPENGL_FOUND "YES")
+
+- SET(wxWidgets_USE_LIBS ${wxWidgets_USE_LIBS} gl )
++ SET(wxWidgets_FIND_COMPONENTS ${wxWidgets_FIND_COMPONENTS} gl )
+ add_subdirectory(src/glshim)
+
+ ENDIF(QT_ANDROID)
+@@ -389,7 +389,7 @@
+
+ IF(OPENGL_FOUND)
+
+- SET(wxWidgets_USE_LIBS gl ${wxWidgets_USE_LIBS} )
++ SET(wxWidgets_FIND_COMPONENTS gl ${wxWidgets_FIND_COMPONENTS} )
+ INCLUDE_DIRECTORIES(${OPENGL_INCLUDE_DIR})
+
+ MESSAGE (STATUS "Found OpenGL...." )
+@@ -432,7 +432,7 @@
+ if(WXWIDGETS_FORCE_VERSION)
+ set (wxWidgets_CONFIG_OPTIONS --version=${WXWIDGETS_FORCE_VERSION})
+ endif()
+-FIND_PACKAGE(wxWidgets REQUIRED)
++FIND_PACKAGE(wxWidgets REQUIRED COMPONENTS ${wxWidgets_FIND_COMPONENTS})
+
+ IF(MSYS)
+ # this is to convert msys to windows paths, and handle the missing /usr
diff --git a/community/opencpn/CMakeList.txt.patch b/community/opencpn/CMakeList.txt.patch
index 8a1341d424..ca55859d25 100644
--- a/community/opencpn/CMakeList.txt.patch
+++ b/community/opencpn/CMakeList.txt.patch
@@ -1,13 +1,14 @@
-index 967e558..27bad69 100644
+https://github.com/OpenCPN/OpenCPN/issues/676
+
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -489,6 +489,9 @@ IF(OCPN_USE_CRASHREPORT)
+@@ -534,6 +534,9 @@
IF(CMAKE_BUILD_TYPE MATCHES "Rel*")
- MESSAGE (STATUS "Using Linux crash reporting")
+ MESSAGE (STATUS "Using Linux crash reporting")
ADD_DEFINITIONS(-DLINUX_CRASHRPT)
+ IF(EXISTS /etc/alpine-release)
+ SET(EXTRA_LIBS ${EXTRA_LIBS} "execinfo")
+ ENDIF(EXISTS alpine-release)
ENDIF(CMAKE_BUILD_TYPE MATCHES "Rel*")
ENDIF(NOT APPLE AND NOT QT_ANDROID AND NOT MINGW)
- ENDIF(MSVC
+ ENDIF(MSVC)