aboutsummaryrefslogtreecommitdiffstats
path: root/community/openexr
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-11 13:31:07 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-13 19:52:52 +0100
commite475ee3c7cfb3824e6fc7b0f4eebe8498aa42bf8 (patch)
treec2705a025ae221c26090b5f084e68ae35039bd34 /community/openexr
parent4d1cbe2230e0df546f74521a95c82e7101877168 (diff)
downloadaports-e475ee3c7cfb3824e6fc7b0f4eebe8498aa42bf8.tar.bz2
aports-e475ee3c7cfb3824e6fc7b0f4eebe8498aa42bf8.tar.xz
community/openexr: fix include and libdir directives in pkgconfig files
Diffstat (limited to 'community/openexr')
-rw-r--r--community/openexr/APKBUILD8
-rw-r--r--community/openexr/fix-pkgconfig-prefix.patch54
2 files changed, 59 insertions, 3 deletions
diff --git a/community/openexr/APKBUILD b/community/openexr/APKBUILD
index 78a760d18a..95dc9d1d42 100644
--- a/community/openexr/APKBUILD
+++ b/community/openexr/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Mark Riedesel <mark+alpine@klowner.com>
pkgname=openexr
pkgver=2.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A high dynamic-range image file format library"
url="https://www.openexr.com/"
arch="all"
license="BSD-3-Clause"
makedepends="zlib-dev cmake"
subpackages="$pkgname-doc $pkgname-dev $pkgname-tools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/openexr/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/openexr/archive/v$pkgver.tar.gz
+ fix-pkgconfig-prefix.patch"
build() {
cmake -B build \
@@ -32,4 +33,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="23c0c07fafa42f832e67cbfeeeb12b6b9e373dd0a5b858f463bf5c4d0661c58fad662cef64ef6a3053f0db2f69aee46816568b814872d617284664d1effbbbab openexr-2.4.1.tar.gz"
+sha512sums="23c0c07fafa42f832e67cbfeeeb12b6b9e373dd0a5b858f463bf5c4d0661c58fad662cef64ef6a3053f0db2f69aee46816568b814872d617284664d1effbbbab openexr-2.4.1.tar.gz
+08a7da593186974583390ab6459d317cb3a2b4ca35e25af1530cc55d16d8c06b07c8388b06134d2035898b6091f601c6e0e0a494a4b0423ba4d7408ead8b905a fix-pkgconfig-prefix.patch"
diff --git a/community/openexr/fix-pkgconfig-prefix.patch b/community/openexr/fix-pkgconfig-prefix.patch
new file mode 100644
index 0000000000..8b13d46527
--- /dev/null
+++ b/community/openexr/fix-pkgconfig-prefix.patch
@@ -0,0 +1,54 @@
+Upstream doesn't prepend ${prefix} to the libdir, incluedir etc., so packages
+which try to use OpenEXR fail to include it because it tries to include
+"-Iinclude/OpenEXR" and not "-I/usr/include/OpenEXR"
+diff --git a/IlmBase/IlmBase.pc.in b/IlmBase/IlmBase.pc.in
+index 45fc4de..b1ac8e8 100644
+--- a/IlmBase/IlmBase.pc.in
++++ b/IlmBase/IlmBase.pc.in
+@@ -4,9 +4,9 @@
+ ##
+
+ prefix=@prefix@
+-exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++exec_prefix=${prefix}/@exec_prefix@
++libdir=${prefix}/@libdir@
++includedir=${prefix}/@includedir@
+ libsuffix=@LIB_SUFFIX_DASH@
+ Name: IlmBase
+ Description: Base math and exception libraries
+diff --git a/OpenEXR/OpenEXR.pc.in b/OpenEXR/OpenEXR.pc.in
+index cf72f88..34fa246 100644
+--- a/OpenEXR/OpenEXR.pc.in
++++ b/OpenEXR/OpenEXR.pc.in
+@@ -4,9 +4,9 @@
+ ##
+
+ prefix=@prefix@
+-exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++exec_prefix=${prefix}/@exec_prefix@
++libdir=${prefix}/@libdir@
++includedir=${prefix}/@includedir@
+ OpenEXR_includedir=@includedir@/OpenEXR
+ libsuffix=@LIB_SUFFIX_DASH@
+
+diff --git a/PyIlmBase/PyIlmBase.pc.in b/PyIlmBase/PyIlmBase.pc.in
+index 7caaf7b..c242e36 100644
+--- a/PyIlmBase/PyIlmBase.pc.in
++++ b/PyIlmBase/PyIlmBase.pc.in
+@@ -4,9 +4,9 @@
+ ##
+
+ prefix=@prefix@
+-exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++exec_prefix=${prefix}/@exec_prefix@
++libdir=${prefix}/@libdir@
++includedir=${prefix}/@includedir@
+ PyIlmBase_includedir=@includedir@/OpenEXR
+
+ Name: PyIlmBase