aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-06-13 04:22:54 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-14 12:19:14 +0000
commit0704a9e5ac3deb205e563d9617bf3f55124bea4b (patch)
tree4b79969ad20c794c89197c8b5db18057ee412a91 /community/openjdk7
parent1e41289fef92764e4e773b7e92e0a344ff0f101e (diff)
downloadaports-0704a9e5ac3deb205e563d9617bf3f55124bea4b.tar.bz2
aports-0704a9e5ac3deb205e563d9617bf3f55124bea4b.tar.xz
community/openjdk7: upgrade to 7.181.2.6.14
Diffstat (limited to 'community/openjdk7')
-rw-r--r--community/openjdk7/APKBUILD44
-rw-r--r--community/openjdk7/icedtea-hotspot-musl-ppc.patch140
-rw-r--r--community/openjdk7/icedtea-hotspot-musl.patch4
3 files changed, 94 insertions, 94 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 2b86618041..b7258bf742 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=openjdk7
-_icedteaver=2.6.11
+_icedteaver=2.6.14
# pkgver is <JDK version>.<JDK update>
# check icedtea JDK when updating
-pkgver=7.151.$_icedteaver
+pkgver=7.181.$_icedteaver
pkgrel=0
pkgdesc="OpenJDK 7 via IcedTea"
-url="http://icedtea.classpath.org/"
+url="https://icedtea.classpath.org/"
arch="all"
license="GPL-2.0 with Classpath"
depends="$pkgname-jre java-cacerts"
@@ -24,8 +24,8 @@ makedepends="bash findutils tar zip file paxmark gawk util-linux libxslt
install=""
# upstream binary versions
-RHINO_VER=1.7.7.1
-ANT_VER=1.9.7
+RHINO_VER=1.7.7.2
+ANT_VER=1.9.11
case $CARCH in
x86) _jarch=i386;;
@@ -59,9 +59,9 @@ else
fi
_dropsver=$_icedteaver
-_dropsurl=http://icedtea.classpath.org/download/drops/icedtea7/$_dropsver
+_dropsurl=https://icedtea.classpath.org/download/drops/icedtea7/$_dropsver
-source="http://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.gz
+source="https://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.gz
openjdk-$_dropsver.tar.bz2::$_dropsurl/openjdk.tar.bz2
corba-$_dropsver.tar.bz2::$_dropsurl/corba.tar.bz2
jaxp-$_dropsver.tar.bz2::$_dropsurl/jaxp.tar.bz2
@@ -69,8 +69,8 @@ source="http://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.gz
jdk-$_dropsver.tar.bz2::$_dropsurl/jdk.tar.bz2
langtools-$_dropsver.tar.bz2::$_dropsurl/langtools.tar.bz2
hotspot-$_dropsver.tar.bz2::$_dropsurl/hotspot.tar.bz2
- http://archive.apache.org/dist/ant/binaries/apache-ant-$ANT_VER-bin.tar.gz
- https://github.com/mozilla/rhino/releases/download/Rhino${RHINO_VER//./_}_RELEASE/rhino-$RHINO_VER.zip
+ https://archive.apache.org/dist/ant/binaries/apache-ant-$ANT_VER-bin.tar.gz
+ https://github.com/mozilla/rhino/releases/download/Rhino${RHINO_VER//./_}_Release/rhino-$RHINO_VER.zip
icedtea-hotspot-musl.patch
icedtea-hotspot-musl-ppc.patch
@@ -148,7 +148,7 @@ build() {
done
echo "icedtea patches: $DISTRIBUTION_PATCHES"
- # --disable-arm32-jit: http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2942
+ # --disable-arm32-jit: https://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2942
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -255,18 +255,18 @@ doc() {
mv "$pkgdir"/$INSTALL_BASE/man "$subpkgdir"/$INSTALL_BASE/
}
-sha512sums="314fa192f9de58c224b1d40a4fe4a15a7a323f3a1454d27487b126a0822ced3d4305fbc401e892530c618a394d5f22e1b64a65a844fe6b0253dc0df36497bd25 icedtea-2.6.11.tar.gz
-95a0168b109266dfe7af97355f34888559f1978201fc7fe9c1b7b15074793d850a68ce031603bb62c4ad6790e8575ebf7e73fca2fdd8f03c9ab0a4e24e3e07b8 openjdk-2.6.11.tar.bz2
-87b374d6907dcd72043cb3a86eed08e836861c238282fdd8c9684b6653b5788f1d183038572282f92dd81381765ac41243c6faa52033173157bb8b48b928d071 corba-2.6.11.tar.bz2
-a08618aca24f80f67669f62743150eaf7a33a602f9b5d806f3c0213261144a15006c4348800e25d5746500735498bc0c8380ee9adc75b6fce17283d9f4971358 jaxp-2.6.11.tar.bz2
-145ae63e81a1c2cce6e462c2b38b05d79d138a89f5f4176151e87a8dcfb27c0b8f47c826ea12d85acdd31733ea253aaf9fbb019e605a4cc24c4b66803ca01f61 jaxws-2.6.11.tar.bz2
-7974d9d7d55c4a57b53ee5e29f36ef058d207eee1701eac0e8b32b8f13a9084b08ff9fcde00cb16f4c23fa6bf371361f183b07f418cd6d200b67a67f86fa6785 jdk-2.6.11.tar.bz2
-6301ca17725dcf085b4dea74d453bb2ec9e7620b6791bdba6cf70fd4fac3f53679c8281db17c343ae4639a3c5431d9af09d76619825e2a8f3072bf46e09a9ce1 langtools-2.6.11.tar.bz2
-8d4bb7a97e2213d21a99261d9f9a32824830f1b178260cb170eeb45ac54414bd26042dc75b2dc719850638571cf8057d7d3fdb65c32fbed8797e6242ba257e7f hotspot-2.6.11.tar.bz2
-85d35441a3ecb1eb5c87b112ee9f3a8accbb16a1b9e249f706f0253566fcda7952f5a9cc08bd8c829b1c93d40ae452e1b1c9e29523a51a3c8a5032fa9c22e135 apache-ant-1.9.7-bin.tar.gz
-fba60e83db6e6dd7ef0a834e8aa6858af41b973e01a54392f11ed1d7d152b9641a48e5d473b434e062e8b8d5d19281da1445751e2b0e297ecd25d2680efc435a rhino-1.7.7.1.zip
-32e603be6f4be91e7cb2bca4fe0c6c81e7ca8728333355d15f553d10675c65885d655dd14982d6e8ac3d82229d9688432d61db5f63852a9d4364f7b76862a35e icedtea-hotspot-musl.patch
-a6b12034217bf7adf0880a7e5697722b109793823a7db303fc1363e14d625976c4a3693a8145f9bdfbdc25180a46d64f21f3460cdc65da2dab03ddedb6bd1247 icedtea-hotspot-musl-ppc.patch
+sha512sums="0fbcb53d1b8e3c3f5e489249d9aab63a32be25d1cace573b241ecbcae6b2788b844f889e8eb9131e629aecd6a8a7a2224161ac475e96e0b21f9a50395374322a icedtea-2.6.14.tar.gz
+7feb3c32ac2b08c3f5abfcc738156209dffd3f0af26b213e5afc2c13ec4547a9cdbb045d76bad9679417fbb4be059e9a688b12262236640caf9b09d5f84cab5c openjdk-2.6.14.tar.bz2
+8ef1d3f4393666c84d0c927c6037f98a45db377c635611fa190b06d52bc52e1edc8f3e8caccc704d72c9d3b4a328c54b4fa5a8aa688c97f09e0850ac2e86fcc4 corba-2.6.14.tar.bz2
+6417b6a400b80e46410bb5918a69461f37d0d6a7aa6de0227225ca4169b5c91beba828b6a9be7797f6d57a93243add3f878f5e3ee0f9d6fc13c12b2ae89eb4d6 jaxp-2.6.14.tar.bz2
+ebc2570c729eb0af7907347663dc86447f03a50566a9251d48f183c17da238cc0278eb370d5ff986ba2e9544b49de7230563227aa8210171ce16f1da73f180c6 jaxws-2.6.14.tar.bz2
+d1a53d46582ae81daca23ce1116cc4f0dd9beef07f1e2059ed2fef8b0b6d6610ebee0a66c437e1c263626f7889910c12d688a037798deb0d241d619f78efdb86 jdk-2.6.14.tar.bz2
+c1dd383b90bf89d770ce0afb838d6beb57edcc52d5172738be4fc11d72a08a4cce6b47bd2598ec2af36e7f752127e9f6d0bc0c20488a5224b6f77a615796feeb langtools-2.6.14.tar.bz2
+9a5fb4fb254e9a01199d42da8dedb121439f7970cbfda319c6085e879d3066c9bcfa780b7e497a24677333b29eec13c4e88beb4228847d3a2ad2f59a3a9c1863 hotspot-2.6.14.tar.bz2
+0da12cb0f761b8cb76e042449e7d93f43236e7bc948e337215470a70031f0a2dda6d1b508f9397b283808d84c4ebddb31558fe1cd8e6e6469c1dd390d69ec6e7 apache-ant-1.9.11-bin.tar.gz
+1b9e8721749e81c5420a00af1e00ee0e4f48624ccb4e9aa969032114116ad50f59b254d4d16d74feff74de64157cc8b0a2ead9b555907c84b7055b796fba9a75 rhino-1.7.7.2.zip
+f62b942f0bacda8e37d0f1876d8ba14ddb4fc55a7d5fd1019463744927f40f422a85e9ee051948d566242f5a785aa28f275eb58768611283cba89af91235f43c icedtea-hotspot-musl.patch
+e5cf4d70f96fc1e72ae8b97a887adb96092ff36584711cbb8de9d9fa9e859cb8731d638838de0d9591239fc44ffe5c74422d1842bd9f10a0c00dff1627bdeeef icedtea-hotspot-musl-ppc.patch
e7a2c1771bb582d427041f8d22e48c0daf8f20d7c0926cbce3549d49c4e949359ee25a35682b486e82f3e390535c950c5beee3bd8d06fb5a717b50f2d9b2a6bc icedtea-hotspot-noagent-musl.patch
822eee0dc4d3ba677a289dfeb3668b536d2d626708390a9d9702fb4144a481fd443a215a0d2041c6026113837aafa4ba0b5e9ead8589d2da6717a238bbc95a5a icedtea-hotspot-uclibc-fixes.patch
213a537de5f011cb39d608515c3413513ac75fb93593f9a9ef4205f71d72bdd8b097c80db185f7b26021d5bb85045b866f34f3478482dc4189972d8614a13458 icedtea-jdk-fix-build.patch
diff --git a/community/openjdk7/icedtea-hotspot-musl-ppc.patch b/community/openjdk7/icedtea-hotspot-musl-ppc.patch
index 161abf349a..eca684884c 100644
--- a/community/openjdk7/icedtea-hotspot-musl-ppc.patch
+++ b/community/openjdk7/icedtea-hotspot-musl-ppc.patch
@@ -1,66 +1,6 @@
---- openjdk.orig/hotspot/src/cpu/ppc/vm/macroAssembler_ppc.cpp
-+++ openjdk/hotspot/src/cpu/ppc/vm/macroAssembler_ppc.cpp
-@@ -1211,7 +1211,11 @@
- // the safepoing polling page.
- ucontext_t* uc = (ucontext_t*) ucontext;
- // Set polling address.
-+#if defined(__GLIBC__) || defined(__UCLIBC__)
- address addr = (address)uc->uc_mcontext.regs->gpr[ra] + (ssize_t)ds;
-+#else // Musl
-+ address addr = (address)uc->uc_mcontext.gp_regs[ra] + (ssize_t)ds;
-+#endif
- if (polling_address_ptr != NULL) {
- *polling_address_ptr = addr;
- }
-@@ -1232,15 +1236,24 @@
- int rb = inv_rb_field(instruction);
-
- // look up content of ra and rb in ucontext
-+#if defined(__GLIBC__) || defined(__UCLIBC__)
- address ra_val=(address)uc->uc_mcontext.regs->gpr[ra];
- long rb_val=(long)uc->uc_mcontext.regs->gpr[rb];
-+#else // Musl
-+ address ra_val=(address)uc->uc_mcontext.gp_regs[ra];
-+ long rb_val=(long)uc->uc_mcontext.gp_regs[rb];
-+#endif
- return os::is_memory_serialize_page(thread, ra_val+rb_val);
- } else if (is_stw(instruction) || is_stwu(instruction)) {
- int ra = inv_ra_field(instruction);
- int d1 = inv_d1_field(instruction);
-
- // look up content of ra in ucontext
-+#if defined(__GLIBC__) || defined(__UCLIBC__)
- address ra_val=(address)uc->uc_mcontext.regs->gpr[ra];
-+#else // Musl
-+ address ra_val=(address)uc->uc_mcontext.gp_regs[ra];
-+#endif
- return os::is_memory_serialize_page(thread, ra_val+d1);
- } else {
- return false;
-@@ -1303,11 +1316,20 @@
- || (is_stdu(instruction) && rs == 1)) {
- int ds = inv_ds_field(instruction);
- // return banged address
-+#if defined(__GLIBC__) || defined(__UCLIBC__)
- return ds+(address)uc->uc_mcontext.regs->gpr[ra];
-+#else // Musl
-+ return ds+(address)uc->uc_mcontext.gp_regs[ra];
-+#endif
- } else if (is_stdux(instruction) && rs == 1) {
- int rb = inv_rb_field(instruction);
-+#if defined(__GLIBC__) || defined(__UCLIBC__)
- address sp = (address)uc->uc_mcontext.regs->gpr[1];
- long rb_val = (long)uc->uc_mcontext.regs->gpr[rb];
-+#else // Musl
-+ address sp = (address)uc->uc_mcontext.gp_regs[1];
-+ long rb_val = (long)uc->uc_mcontext.gp_regs[rb];
-+#endif
- return ra != 1 || rb_val >= 0 ? NULL // not a stack bang
- : sp + rb_val; // banged address
- }
--- openjdk.orig/hotspot/src/os_cpu/linux_ppc/vm/os_linux_ppc.cpp
+++ openjdk/hotspot/src/os_cpu/linux_ppc/vm/os_linux_ppc.cpp
-@@ -123,11 +123,19 @@
+@@ -110,11 +110,19 @@
// it because the volatile registers are not needed to make setcontext() work.
// Hopefully it was zero'd out beforehand.
guarantee(uc->uc_mcontext.regs != NULL, "only use ucontext_get_pc in sigaction context");
@@ -80,7 +20,7 @@
}
intptr_t* os::Linux::ucontext_get_fp(ucontext_t * uc) {
-@@ -226,7 +234,11 @@
+@@ -213,7 +221,11 @@
if (uc) {
address const pc = os::Linux::ucontext_get_pc(uc);
if (pc && StubRoutines::is_safefetch_fault(pc)) {
@@ -92,7 +32,7 @@
return true;
}
}
-@@ -370,7 +382,11 @@
+@@ -364,7 +376,11 @@
// continue at the next instruction after the faulting read. Returning
// garbage from this read is ok.
thread->set_pending_unsafe_access_error();
@@ -104,7 +44,7 @@
return true;
}
}
-@@ -389,7 +405,11 @@
+@@ -383,7 +399,11 @@
// continue at the next instruction after the faulting read. Returning
// garbage from this read is ok.
thread->set_pending_unsafe_access_error();
@@ -116,19 +56,19 @@
return true;
}
}
-@@ -412,7 +432,11 @@
+@@ -406,7 +426,11 @@
if (stub != NULL) {
// Save all thread context in case we need to restore it.
if (thread != NULL) thread->set_saved_exception_pc(pc);
+#if defined(__GLIBC__) || defined(__UCLIBC__)
uc->uc_mcontext.regs->nip = (unsigned long)stub;
-+#else // Musl
++#else
+ uc->uc_mcontext.gp_regs[32] = (unsigned long)stub;
+#endif
return true;
}
-@@ -570,6 +594,7 @@
+@@ -564,6 +588,7 @@
ucontext_t* uc = (ucontext_t*)context;
st->print_cr("Registers:");
@@ -136,7 +76,7 @@
st->print("pc =" INTPTR_FORMAT " ", uc->uc_mcontext.regs->nip);
st->print("lr =" INTPTR_FORMAT " ", uc->uc_mcontext.regs->link);
st->print("ctr=" INTPTR_FORMAT " ", uc->uc_mcontext.regs->ctr);
-@@ -578,8 +603,18 @@
+@@ -572,8 +597,18 @@
st->print("r%-2d=" INTPTR_FORMAT " ", i, uc->uc_mcontext.regs->gpr[i]);
if (i % 3 == 2) st->cr();
}
@@ -154,8 +94,8 @@
+ st->cr();
intptr_t *sp = (intptr_t *)os::Linux::ucontext_get_sp(uc);
- st->print_cr("Top of Stack: (sp=" PTR_FORMAT ")", sp);
-@@ -606,7 +641,11 @@
+ st->print_cr("Top of Stack: (sp=" PTR_FORMAT ")", p2i(sp));
+@@ -600,7 +635,11 @@
// this is only for the "general purpose" registers
for (int i = 0; i < 32; i++) {
st->print("r%-2d=", i);
@@ -167,3 +107,63 @@
}
st->cr();
}
+--- openjdk.orig/hotspot.orig/src/cpu/ppc/vm/macroAssembler_ppc.cpp
++++ openjdk/hotspot/src/cpu/ppc/vm/macroAssembler_ppc.cpp
+@@ -1242,7 +1242,11 @@
+ // the safepoing polling page.
+ ucontext_t* uc = (ucontext_t*) ucontext;
+ // Set polling address.
++#if defined(__GLIBC__) || defined(__UCLIBC__)
+ address addr = (address)uc->uc_mcontext.regs->gpr[ra] + (ssize_t)ds;
++#else // Musl
++ address addr = (address)uc->uc_mcontext.gp_regs[ra] + (ssize_t)ds;
++#endif
+ if (polling_address_ptr != NULL) {
+ *polling_address_ptr = addr;
+ }
+@@ -1263,15 +1267,24 @@
+ int rb = inv_rb_field(instruction);
+
+ // look up content of ra and rb in ucontext
++#if defined(__GLIBC__) || defined(__UCLIBC__)
+ address ra_val=(address)uc->uc_mcontext.regs->gpr[ra];
+ long rb_val=(long)uc->uc_mcontext.regs->gpr[rb];
++#else // Musl
++ address ra_val=(address)uc->uc_mcontext.gp_regs[ra];
++ long rb_val=(long)uc->uc_mcontext.gp_regs[rb];
++#endif
+ return os::is_memory_serialize_page(thread, ra_val+rb_val);
+ } else if (is_stw(instruction) || is_stwu(instruction)) {
+ int ra = inv_ra_field(instruction);
+ int d1 = inv_d1_field(instruction);
+
+ // look up content of ra in ucontext
++#if defined(__GLIBC__) || defined(__UCLIBC__)
+ address ra_val=(address)uc->uc_mcontext.regs->gpr[ra];
++#else // Musl
++ address ra_val=(address)uc->uc_mcontext.gp_regs[ra];
++#endif
+ return os::is_memory_serialize_page(thread, ra_val+d1);
+ } else {
+ return false;
+@@ -1334,11 +1347,20 @@
+ || (is_stdu(instruction) && rs == 1)) {
+ int ds = inv_ds_field(instruction);
+ // return banged address
++#if defined(__GLIBC__) || defined(__UCLIBC__)
+ return ds+(address)uc->uc_mcontext.regs->gpr[ra];
++#else // Musl
++ return ds+(address)uc->uc_mcontext.gp_regs[ra];
++#endif
+ } else if (is_stdux(instruction) && rs == 1) {
+ int rb = inv_rb_field(instruction);
++#if defined(__GLIBC__) || defined(__UCLIBC__)
+ address sp = (address)uc->uc_mcontext.regs->gpr[1];
+ long rb_val = (long)uc->uc_mcontext.regs->gpr[rb];
++#else // Musl
++ address sp = (address)uc->uc_mcontext.gp_regs[1];
++ long rb_val = (long)uc->uc_mcontext.gp_regs[rb];
++#endif
+ return ra != 1 || rb_val >= 0 ? NULL // not a stack bang
+ : sp + rb_val; // banged address
+ }
diff --git a/community/openjdk7/icedtea-hotspot-musl.patch b/community/openjdk7/icedtea-hotspot-musl.patch
index 1f980bcbcb..1da9031486 100644
--- a/community/openjdk7/icedtea-hotspot-musl.patch
+++ b/community/openjdk7/icedtea-hotspot-musl.patch
@@ -31,9 +31,9 @@
#ifdef AMD64
#define REG_SP REG_RSP
-@@ -532,6 +531,9 @@
-
+@@ -533,6 +532,9 @@
ShouldNotReachHere();
+ return true; // Mute compiler
}
+
+#define _FPU_GETCW(cw) __asm__ __volatile__ ("fnstcw %0" : "=m" (*&cw))