aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-01 08:51:38 +0100
committerTBK <tbk@jjtc.eu>2020-03-23 14:33:48 +0100
commit39ff0441afcff96ec2383e29077e0d725fc950b8 (patch)
tree9fd51ae7a8608ee7617d425904b5d9f55317eb6f /community/openjdk7
parent6624931a010af68e9e9219e9ebf63d2f9486497c (diff)
downloadaports-39ff0441afcff96ec2383e29077e0d725fc950b8.tar.bz2
aports-39ff0441afcff96ec2383e29077e0d725fc950b8.tar.xz
community/openjdk7: remove paxmark
Diffstat (limited to 'community/openjdk7')
-rw-r--r--community/openjdk7/APKBUILD16
1 files changed, 2 insertions, 14 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 1c311b8aa3..d31234b83f 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -14,15 +14,13 @@ arch="all"
license="GPL-2.0 with Classpath"
depends="$pkgname-jre java-cacerts"
options="sover-namecheck"
-makedepends="bash findutils tar zip file paxmark gawk util-linux libxslt
- autoconf automake linux-headers coreutils
- ca-certificates
+makedepends="bash findutils tar zip file gawk util-linux libxslt
+ autoconf automake linux-headers coreutils ca-certificates
nss-dev cups-dev jpeg-dev giflib-dev libpng-dev libxt-dev
lcms2-dev libxp-dev libxtst-dev libxinerama-dev zlib-dev
libxrender-dev alsa-lib-dev freetype-dev fontconfig-dev
gtk+2.0-dev krb5-dev pcsc-lite-dev lksctp-tools-dev
libxcomposite-dev nss-static xz"
-install=""
# upstream binary versions
RHINO_VER=1.7.7.2
@@ -191,7 +189,6 @@ build() {
--with-jaxws-src-zip=$srcdir/jaxws-$_dropsver.tar.bz2 \
--with-jdk-src-zip=$srcdir/jdk-$_dropsver.tar.bz2 \
--with-langtools-src-zip=$srcdir/langtools-$_dropsver.tar.bz2 \
- --with-pax=paxmark \
--with-jdk-home=$BOOTSTRAP_JAVA_HOME \
--with-pkgversion="Alpine ${pkgver}-r${pkgrel}"
@@ -206,9 +203,6 @@ package() {
cp -a "$builddir"/openjdk.build/j2sdk-image/* "$pkgdir"/$INSTALL_BASE
rm "$pkgdir"/$INSTALL_BASE/src.zip
- # pax mark again (due to fakeroot xattr handling bug)
- "$builddir"/pax-mark-vm "$pkgdir"/$INSTALL_BASE
-
# symlink to shared java cacerts store
rm -f "$pkgdir"/$INSTALL_BASE/jre/lib/security/cacerts
ln -sf /etc/ssl/certs/java/cacerts \
@@ -242,9 +236,6 @@ jrebase() {
# rest of the jre subdir (which were not taken by -jre subpkg)
mv "$pkgdir"/$INSTALL_BASE/jre "$subpkgdir"/$INSTALL_BASE
-
- # pax mark again (due to fakeroot xattr handling bug)
- "$builddir"/pax-mark-vm "$subpkgdir"/$INSTALL_BASE
}
jre() {
@@ -263,9 +254,6 @@ jre() {
mkdir -p "$subpkgdir"/$INSTALL_BASE/$dirname
mv "$pkgdir"/$INSTALL_BASE/$A "$subpkgdir"/$INSTALL_BASE/$dirname
done
-
- # pax mark again (due to fakeroot xattr handling bug)
- "$builddir"/pax-mark-vm "$subpkgdir"/$INSTALL_BASE
}
doc() {