aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-22 18:22:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-22 18:57:32 +0200
commitd35207be0aa48d9936013e733207f0cf112e7c12 (patch)
tree05a858b4ec8d7de72b2db61008b3c922258dd64d /community/openjdk7
parent1151eb805683ac3a9dce256e41d133943ffd2f97 (diff)
downloadaports-d35207be0aa48d9936013e733207f0cf112e7c12.tar.bz2
aports-d35207be0aa48d9936013e733207f0cf112e7c12.tar.xz
community/openjdk7: fix build on gcc6
Diffstat (limited to 'community/openjdk7')
-rw-r--r--community/openjdk7/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 910e97083e..59e9751033 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -6,7 +6,7 @@ _icedteaver=2.6.3
# pkgver is <JDK version>.<JDK update>
# check icedtea JDK when updating
pkgver=7.91.$_icedteaver
-pkgrel=2
+pkgrel=3
pkgdesc="Sun OpenJDK 7 via IcedTea"
url="http://icedtea.classpath.org/"
arch="all"
@@ -124,6 +124,14 @@ build() {
export PATH=$JAVA_HOME/bin:$srcdir/apache-ant-$ANT_VER/bin:$PATH
export DISTRIBUTION_PATCHES=""
+ # Explicitly set the C++ standard as the default has changed on GCC 6+
+ # and disable optimizations that lead to a broken JVM. These options
+ # has been adopted from the Fedora package.
+ export EXTRA_CPP_FLAGS="$CFLAGS -std=gnu++98 -fno-delete-null-pointer-checks -fno-lifetime-dse"
+ # CXXFLAGS doesn't make it to all calls, so we set the C++ standard
+ # version for C too.
+ export EXTRA_CFLAGS="$CXXFLAGS -std=gnu++98 -Wno-error -fno-delete-null-pointer-checks -fno-lifetime-dse"
+
local patch
for patch in $source; do
case $patch in