aboutsummaryrefslogtreecommitdiffstats
path: root/community/openlibm
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-17 13:55:28 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-17 13:55:28 +0200
commitbc52d297bf9ff9eef62a26f58b5e8825fefeb597 (patch)
tree8bae1cc22de9a6e6d81039ffde0dbf837b05bede /community/openlibm
parent6f3690217faee1b47b8355502924353229bf0bb0 (diff)
downloadaports-bc52d297bf9ff9eef62a26f58b5e8825fefeb597.tar.bz2
aports-bc52d297bf9ff9eef62a26f58b5e8825fefeb597.tar.xz
community/openlibm: moved from testing
Diffstat (limited to 'community/openlibm')
-rw-r--r--community/openlibm/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/openlibm/APKBUILD b/community/openlibm/APKBUILD
new file mode 100644
index 0000000000..f354b7a8f0
--- /dev/null
+++ b/community/openlibm/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=openlibm
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="High quality system independent, portable, open source libm implementation"
+url="http://www.openlibm.org"
+arch="all"
+license="MIT BSD public-domain"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make VERSION=$pkgver DESTDIR="$pkgdir" prefix=/usr install
+}
+
+md5sums="0733b1f9d7913a1f9421fc4ffeac174c openlibm-0.5.3.tar.gz"
+sha256sums="e86d001dfd05557e900e424bdc85024dbd5f00ad194d4607feb39c6f4d117512 openlibm-0.5.3.tar.gz"
+sha512sums="b397482b00cd51b2e66dceff2c4c5ba58bb05b6ae9d16cdaecb2bb05a9accbd84ae4c5387a8ef31c49928a61776de21fed48943d551ec3f65e2943e9ac8ef2f8 openlibm-0.5.3.tar.gz"